summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2019-08-24 02:49:41 +0200
committer Willy Sudiarto Raharjo2019-08-24 03:22:58 +0200
commit67cb0aab24ad97b5174cf8cccf0d0b44fa751d92 (patch)
tree6b11d5a6195bfbc47b2a8598cb487527d04672d0
parent2e49de07f7a6ee7c15b1c412280a572f7b979349 (diff)
downloadslackbuilds-67cb0aab24ad97b5174cf8cccf0d0b44fa751d92.tar.gz
python/python-odict: Removed (replaced with odict).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-odict/README3
-rw-r--r--python/python-odict/python-odict.SlackBuild87
-rw-r--r--python/python-odict/python-odict.info10
-rw-r--r--python/python-odict/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/python-odict/README b/python/python-odict/README
deleted file mode 100644
index a7980e171b..0000000000
--- a/python/python-odict/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Dictionary in which the insertion order of items is preserved
-(using an internal double linked list). In this implementation
-replacing an existing item keeps it at its original position.
diff --git a/python/python-odict/python-odict.SlackBuild b/python/python-odict/python-odict.SlackBuild
deleted file mode 100644
index 7aa8167686..0000000000
--- a/python/python-odict/python-odict.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-odict
-
-# Copyright (c) 2017 Cristiano Urban, Gonars, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-odict
-VERSION=${VERSION:-1.6.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=odict
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst LICENSE.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-odict/python-odict.info b/python/python-odict/python-odict.info
deleted file mode 100644
index 1e1a12b188..0000000000
--- a/python/python-odict/python-odict.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-odict"
-VERSION="1.6.2"
-HOMEPAGE="https://github.com/bluedynamics/odict"
-DOWNLOAD="https://github.com/bluedynamics/odict/archive/1.6.2/odict-1.6.2.tar.gz"
-MD5SUM="dc2ffd43fa7d32b2da146b0ea49fb14e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Cristiano Urban"
-EMAIL="cristiano.urban.slack@gmail.com"
diff --git a/python/python-odict/slack-desc b/python/python-odict/slack-desc
deleted file mode 100644
index 9a922bdae2..0000000000
--- a/python/python-odict/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-odict: python-odict (ordered dictionary)
-python-odict:
-python-odict: Dictionary in which the insertion order of items is preserved
-python-odict: (using an internal double linked list). In this implementation
-python-odict: replacing an existing item keeps it at its original position.
-python-odict:
-python-odict: Homepage: https://github.com/bluedynamics/odict
-python-odict:
-python-odict:
-python-odict:
-python-odict: