summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu2022-07-14 06:49:06 +0200
committer Willy Sudiarto Raharjo2022-07-17 01:40:12 +0200
commit8182340f6d244a271b2c64421bc1253894514010 (patch)
treeab2ed0fe76d75922068fc7c175acecb349e51008
parent985b3c1b64fe6de2749fcf1ef22558e14be84508 (diff)
downloadslackbuilds-8182340f6d244a271b2c64421bc1253894514010.tar.gz
development/jupyter_core: Updated for version 4.11.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/jupyter_core/jupyter_core.SlackBuild30
-rw-r--r--development/jupyter_core/jupyter_core.info6
2 files changed, 31 insertions, 5 deletions
diff --git a/development/jupyter_core/jupyter_core.SlackBuild b/development/jupyter_core/jupyter_core.SlackBuild
index 3186f866e1..19ff1ec940 100644
--- a/development/jupyter_core/jupyter_core.SlackBuild
+++ b/development/jupyter_core/jupyter_core.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter_core
-VERSION=${VERSION:-4.10.0}
+VERSION=${VERSION:-4.11.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,33 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Use this setup.py shim:
+cat << EOF > setup.py
+from setuptools import setup
+import os
+here = os.path.abspath(os.path.dirname(__file__))
+pjoin = os.path.join
+packages = []
+for d, _, _ in os.walk(pjoin(here, 'jupyter_core')):
+ packages.append(d[len(here)+1:].replace(os.path.sep, '.'))
+setup(name='${PRGNAM}',
+ version='${VERSION}',
+ packages=packages,
+ py_modules=['jupyter'],
+ entry_points={
+ 'console_scripts': [
+ 'jupyter = jupyter_core.command:main',
+ 'jupyter-migrate = jupyter_core.migrate:main',
+ 'jupyter-troubleshoot = jupyter_troubleshoot.migrate:main',
+ ],
+ },
+ package_data={'': ['*']},
+)
+EOF
+
+# With the shim, it's a good idea to use "unshare -n" to prevent downloading
+# anything extra:
+unshare -n python3 setup.py install --root=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/development/jupyter_core/jupyter_core.info b/development/jupyter_core/jupyter_core.info
index 57e60a4caa..313df9c0b7 100644
--- a/development/jupyter_core/jupyter_core.info
+++ b/development/jupyter_core/jupyter_core.info
@@ -1,8 +1,8 @@
PRGNAM="jupyter_core"
-VERSION="4.10.0"
+VERSION="4.11.1"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/jupyter/jupyter_core/archive/4.10.0/jupyter_core-4.10.0.tar.gz"
-MD5SUM="24a4dcc46af8422dc7f982ff949844d0"
+DOWNLOAD="https://github.com/jupyter/jupyter_core/archive/4.11.1/jupyter_core-4.11.1.tar.gz"
+MD5SUM="215d4a5171e12da232c719219be141e2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="traitlets"