summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Heinz Wiesinger2022-07-08 07:13:52 +0200
committer Willy Sudiarto Raharjo2022-07-09 05:06:07 +0200
commit438988dc356676f7d574eb5b08b5716099481ef4 (patch)
tree4a3a23cbe37efc19c85d45a69d26ab69cc3c2ebd
parent4e056bd834ed2275dce26f92110151b137f77d15 (diff)
downloadslackbuilds-438988dc356676f7d574eb5b08b5716099481ef4.tar.gz
python/python3-installer: Added (Install Py packages from wheels)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-installer/README3
-rw-r--r--python/python3-installer/python3-installer.SlackBuild82
-rw-r--r--python/python3-installer/python3-installer.info10
-rw-r--r--python/python3-installer/slack-desc19
4 files changed, 114 insertions, 0 deletions
diff --git a/python/python3-installer/README b/python/python3-installer/README
new file mode 100644
index 0000000000..46ae1e6e70
--- /dev/null
+++ b/python/python3-installer/README
@@ -0,0 +1,3 @@
+This is a low-level library for installing a Python package from a
+wheel distribution. It provides basic functionality and abstractions
+for handling wheels and installing packages from wheels.
diff --git a/python/python3-installer/python3-installer.SlackBuild b/python/python3-installer/python3-installer.SlackBuild
new file mode 100644
index 0000000000..bf581e40c0
--- /dev/null
+++ b/python/python3-installer/python3-installer.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Slackware build script for python3-installer
+
+# Copyright 2022 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-installer
+SRCNAM=installer
+VERSION=${VERSION:-0.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CONTRIBUTING.md LICENSE PKG-INFO README.md docs $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-installer/python3-installer.info b/python/python3-installer/python3-installer.info
new file mode 100644
index 0000000000..8a71fd2bc2
--- /dev/null
+++ b/python/python3-installer/python3-installer.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-installer"
+VERSION="0.5.1"
+HOMEPAGE="https://github.com/pypa/installer"
+DOWNLOAD="https://files.pythonhosted.org/packages/74/b7/9187323cd732840f1cddd6a9f05961406636b50c799eef37c920b63110c0/installer-0.5.1.tar.gz"
+MD5SUM="bf17db5e6b58c4cfa33642f5348d3814"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@slackbuilds.org"
diff --git a/python/python3-installer/slack-desc b/python/python3-installer/slack-desc
new file mode 100644
index 0000000000..1cc43bf762
--- /dev/null
+++ b/python/python3-installer/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-installer: python3-installer (Library for installing Python packages from wheels)
+python3-installer:
+python3-installer: This is a low-level library for installing a Python package from a
+python3-installer: wheel distribution. It provides basic functionality and abstractions
+python3-installer: for handling wheels and installing packages from wheels.
+python3-installer:
+python3-installer:
+python3-installer:
+python3-installer:
+python3-installer:
+python3-installer: