summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pr. HORSTMANN2020-12-11 19:40:19 +0100
committer Willy Sudiarto Raharjo2020-12-12 01:09:20 +0100
commit052e5b9e57497ebe42fa62d8c6894d0e8520e682 (patch)
tree9075c91a09ac228cf6ca66bc019e77fb86e02708
parentb4810501883a9c178cfd1d988b2f7bbbd588dd5e (diff)
downloadslackbuilds-052e5b9e57497ebe42fa62d8c6894d0e8520e682.tar.gz
python/click-didyoumean: Added (git-like did-you-mean feature)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/click-didyoumean/README6
-rw-r--r--python/click-didyoumean/click-didyoumean.SlackBuild81
-rw-r--r--python/click-didyoumean/click-didyoumean.info10
-rw-r--r--python/click-didyoumean/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/click-didyoumean/README b/python/click-didyoumean/README
new file mode 100644
index 0000000000..0c6cd35470
--- /dev/null
+++ b/python/click-didyoumean/README
@@ -0,0 +1,6 @@
+Enable git-like did-you-mean feature in click.
+For Python2 and Python3.
+
+OPTIONAL:
+
+python3
diff --git a/python/click-didyoumean/click-didyoumean.SlackBuild b/python/click-didyoumean/click-didyoumean.SlackBuild
new file mode 100644
index 0000000000..2f17f920ec
--- /dev/null
+++ b/python/click-didyoumean/click-didyoumean.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/sh
+
+# SlackBuild build script for click-didyoumean
+
+# Copyright (c) 2000-2011 Pr. Horstmann <wmh (at) eipg.fr>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=click-didyoumean
+SRCPKG=${SRCPKG-click-didyoumean}
+VERSION=${VERSION:-0.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $SRCPKG | cut -d- -f1-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+#set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Python 2.7 will be droped in the future.
+if $(python2 -c 'import sys' 2>/dev/null); then
+ python2 setup.py install --root=$PKG
+ else
+ python setup.py install --root=$PKG
+fi
+
+# Replacement of python-2.x Python3.x check presence and build if found.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}
diff --git a/python/click-didyoumean/click-didyoumean.info b/python/click-didyoumean/click-didyoumean.info
new file mode 100644
index 0000000000..76299c5fe8
--- /dev/null
+++ b/python/click-didyoumean/click-didyoumean.info
@@ -0,0 +1,10 @@
+PRGNAM="click-didyoumean"
+VERSION="0.0.3"
+HOMEPAGE="https://pypi.org/project/click-didyoumean/"
+DOWNLOAD="https://files.pythonhosted.org/packages/9f/79/d265d783dd022541b744d002745d9e55d84c04a41930e35d8795934f6526/click-didyoumean-0.0.3.tar.gz"
+MD5SUM="08ac34aa0355f58ffc43ee57f1969ffb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Pr. HORSTMANN"
+EMAIL="wmh@eipg.fr"
diff --git a/python/click-didyoumean/slack-desc b/python/click-didyoumean/slack-desc
new file mode 100644
index 0000000000..c3cd09ad2b
--- /dev/null
+++ b/python/click-didyoumean/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+click-didyoumean: click-didyoumean (Enable git-like did-you-mean feature in click.)
+click-didyoumean:
+click-didyoumean: Use specific did-you-mean group class for your cli:
+click-didyoumean: Or you it in a CommandCollection:
+click-didyoumean:
+click-didyoumean: max_suggestions int 3 Maximal number of did-you-mean suggestions
+click-didyoumean: There are two configuration for the DYMGroup and DYMCommandCollection:
+click-didyoumean: cutoff float 0.5 Possibilities that don’t score at least that similar
+click-didyoumean: to word are ignored.
+click-didyoumean:
+click-didyoumean: Homepage: https://pypi.org/project/click-didyoumean/