summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author shelldweller2020-06-14 12:40:09 +0200
committer Willy Sudiarto Raharjo2020-06-14 12:45:46 +0200
commitcce60d16aa760591a8ce3cd5c06649328997321d (patch)
treef9881cbdb930d9e564ff96de89d01215e13a8569
parentfbc8d01eabffab852655a0d1a7668468be8b6ea7 (diff)
downloadslackbuilds-cce60d16aa760591a8ce3cd5c06649328997321d.tar.gz
network/i2pd: Added (I2P Daemon)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/i2pd/README13
-rw-r--r--network/i2pd/i2pd.SlackBuild101
-rw-r--r--network/i2pd/i2pd.info10
-rw-r--r--network/i2pd/slack-desc19
4 files changed, 143 insertions, 0 deletions
diff --git a/network/i2pd/README b/network/i2pd/README
new file mode 100644
index 0000000000..1bf6549857
--- /dev/null
+++ b/network/i2pd/README
@@ -0,0 +1,13 @@
+i2pd (I2P Daemon) is a full-featured C++ implementation of I2P client.
+
+I2P (Invisible Internet Protocol) is a universal anonymous network layer.
+All communications over I2P are anonymous and end-to-end encrypted,
+participants don't reveal their real IP addresses.
+
+I2P client is a software used for building and using anonymous I2P networks.
+Such networks are commonly used for anonymous peer-to-peer applications
+(filesharing, cryptocurrencies) and anonymous client-server applications
+(websites, instant messengers, chat-servers).
+
+I2P allows people from all around the world to communicate and share
+information without restrictions.
diff --git a/network/i2pd/i2pd.SlackBuild b/network/i2pd/i2pd.SlackBuild
new file mode 100644
index 0000000000..d9cfd600f7
--- /dev/null
+++ b/network/i2pd/i2pd.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# Slackbuild for i2pd
+
+# Written by shelldweller <shelldweller@beauxbead.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=i2pd
+VERSION=${VERSION:-2.32.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cd build
+sed -i \
+ "s,LIBRARY DESTINATION lib,LIBRARY DESTINATION lib${LIBDIRSUFFIX}," \
+ CMakeLists.txt
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_STATIC=OFF \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_BUILD_TYPE=Release .
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog LICENSE README.md docs/ \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -name "Makefile" -delete
+find $PKG/usr/doc -type f -exec chmod 644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/i2pd/i2pd.info b/network/i2pd/i2pd.info
new file mode 100644
index 0000000000..278d4e5cc4
--- /dev/null
+++ b/network/i2pd/i2pd.info
@@ -0,0 +1,10 @@
+PRGNAM="i2pd"
+VERSION="2.32.1"
+HOMEPAGE="http://i2pd.website/"
+DOWNLOAD="https://github.com/PurpleI2P/i2pd/archive/2.32.1/i2pd-2.32.1.tar.gz"
+MD5SUM="a0d992134cd2731e95fae072f2058e1c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="shelldweller"
+EMAIL="shelldweller@beauxbead.com"
diff --git a/network/i2pd/slack-desc b/network/i2pd/slack-desc
new file mode 100644
index 0000000000..7f7d653ce4
--- /dev/null
+++ b/network/i2pd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+i2pd: i2pd (I2P Daemon)
+i2pd:
+i2pd: A full-featured C++ implementation of an I2P client.
+i2pd:
+i2pd: An I2P client is software used for building and using anonymous I2P
+i2pd: networks. Such networks are commonly used for anonymous peer-to-peer
+i2pd: applications (filesharing, cryptocurrencies) and anonymous client-
+i2pd: server applications (websites, instant messengers, chat-servers).
+i2pd:
+i2pd: I2P allows people from all around the world to communicate and share
+i2pd: information without restrictions.