summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Tim Dickson2020-06-04 18:18:09 +0200
committer Willy Sudiarto Raharjo2020-06-04 18:18:09 +0200
commit226f6a19833626f3f7263ad81279c1f017df3ac0 (patch)
treec9f308e51e29c033c540fb00a4536a40d46d41b9
parent4516985ab209437061afac5e8753b769e3f127cf (diff)
downloadslackbuilds-226f6a19833626f3f7263ad81279c1f017df3ac0.tar.gz
academic/xiphos: Updated for version 4.2.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--academic/xiphos/README28
-rw-r--r--academic/xiphos/xiphos.SlackBuild92
-rw-r--r--academic/xiphos/xiphos.info8
3 files changed, 74 insertions, 54 deletions
diff --git a/academic/xiphos/README b/academic/xiphos/README
index 1860dba832..bfb4df1131 100644
--- a/academic/xiphos/README
+++ b/academic/xiphos/README
@@ -5,24 +5,12 @@ Sword project by the CrossWire Bible Society.
computer reading of the text using festival has not been tested.
if it works let me know, and i'll remove these two lines from the readme.
-if you pass the variable WK2=yes to the build script, the dependencies
-change slightly. instead of webkitgtk3, webkit2gtk and gtkhtml (v4) are
-required.
+xiphos version 4.2.1 requires sword v1.8.1-3 or higher
+and biblesync v2.0.1 or higher
-note: End program differences between webkit and webkit2 versions.
-webkit:
- studypad is missing the image for the "bold" text button (but it works)
- reported not to work with current
-webkit2:
- studypad has an "add emoticon" button, but the images included are not
-found, so an empty imagebox is added in the text if you try to add an icon.
- a few warnings shown on compile (but seems to work just fine).
- try this one for current. if it works, let me know, and I might change
- the default to WK2 :-).
-
-For both versions, there is an issue where if the previewer is in the sidebar,
-text is offset to the left, so you can't see the first 2 characters of each
-line. This can be fixed by making the sidebar a little bit wider.
-
-Note. xiphos version 4.1.0 requires sword v1.8 or higher
-and biblesync v1.2 or higher
+xiphos needs a version of cmake 3.11 or higher. A private version is included
+in the slackbuild to enable xiphos to be built. If you want to use a different
+cmake to that included here, pass CMVERSION with the version you need (and
+make sure that the source tar.gz is available)
+There are a few new dependencies as the documentation is now created by the
+build process rather than shipped preprocessed in the source.
diff --git a/academic/xiphos/xiphos.SlackBuild b/academic/xiphos/xiphos.SlackBuild
index cd9533ba6f..e371fc5854 100644
--- a/academic/xiphos/xiphos.SlackBuild
+++ b/academic/xiphos/xiphos.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for xiphos
-# Copyright 2015-2018 Tim Dickson, email: dickson.tim@googlemail.com
+# Copyright 2015-2020 Tim Dickson, email: dickson.tim@googlemail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,11 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=xiphos
-VERSION=${VERSION:-4.1.0}
+VERSION=${VERSION:-4.2.1}
+CMVERSION=${CMVERSION:-3.17.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-#if WK2 is yes use webkit2. this requires webkit2gtk and gtkhtml (v4) instead of webkitgtk3
-WK2=${WK2:-no}
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -65,45 +63,79 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+
+#we need a private copy of a newer version of cmake (at least 3.11)
+tar xvf $CWD/cmake-$CMVERSION.tar.gz
+
+#sane permissions for everything
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-./waf distclean
+#
+#now do private cmake stuff - note capital C
+cd CMake-$CMVERSION
+mkdir cmake-build
+cd cmake-build
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+ ../configure \
+ --prefix=$TMP/$PRGNAM-$VERSION/tmpcmake \
+ --docdir=/doc \
+ --no-qt-gui \
+ --system-curl \
+ --system-expat \
+ --no-system-jsoncpp \
+ --system-zlib \
+ --system-bzip2 \
+ --system-libarchive
+#we don't care about the docs really as this is a temp install.
+make
+make install
+#hopefully that has installed our tmp cmake in the right place
+#in $TMP/$PRGNAM-$VERSION/tmpcmake/bin
+#lets make it available to the xiphos build
+OLDPATH=$PATH
+export PATH=$TMP/$PRGNAM-$VERSION/tmpcmake/bin:$PATH
+#move back to the right directory
+cd ../../
# patch navbar_versekey.gtkbuilder to work with gtk shipped with slackware 14.2
# patch won't be needed for slackware 15
sed -i "s/3.20/3.14/g" ui/navbar_versekey.gtkbuilder
-if [ "x$WK2" = "xyes" ]; then
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ./waf configure \
- --prefix=/usr \
- --enable-webkit2 \
- --gtk=3
- # --disable-dbus
- # --gtk=2 doesn't work with webkitgtk as gtk2 is disabled
-else
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ./waf configure \
- --prefix=/usr \
- --enable-webkit-editor \
- --gtk=3
- # --disable-dbus
- # --gtk=2 doesn't work with webkitgtk as gtk2 is disabled
-fi
-
-./waf build
-./waf install --destdir=$PKG
-
+mkdir -p build
+cd build
+cmake -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DHTMLHELP=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DDBUS=OFF -DSTRIP=ON -DPOSTINST=OFF -DGTKHTML=ON ..
+
+#unfortunately this CMakeLists.txt ignores MAN_INSTALL_DIR so we fix it later
+#cmake should have created make file so restore PATH
+export PATH=$OLDPATH
+make
+make install DESTDIR=$PKG
+cd ..
+
+#output should be stripped but we just make sure..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+#compress man pages. first, stick them in the right place..
+mkdir -p $PKG/usr/man/man1
+cp $PKG/usr/share/man/man1/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
+rm -rf $PKG/usr/share/man
+#now to compress them
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/academic/xiphos/xiphos.info b/academic/xiphos/xiphos.info
index d2cd894617..b210cffe1d 100644
--- a/academic/xiphos/xiphos.info
+++ b/academic/xiphos/xiphos.info
@@ -1,10 +1,10 @@
PRGNAM="xiphos"
-VERSION="4.1.0"
+VERSION="4.2.1"
HOMEPAGE="http://xiphos.org"
-DOWNLOAD="https://github.com/crosswire/xiphos/releases/download/4.1.0/xiphos-4.1.0.tar.gz"
-MD5SUM="f40c5b249c50a49af71de94420ee720d"
+DOWNLOAD="https://github.com/crosswire/xiphos/releases/download/4.2.1/xiphos-4.2.1.tar.gz https://github.com/KitWare/CMake/archive/v3.17.2/cmake-3.17.2.tar.gz"
+MD5SUM="77d8a99c063433bea3006954710b2fd5 41e0259ede89083081d3276ecaba5b38"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="sword webkitgtk3 biblesync rarian %README%"
+REQUIRES="sword webkitgtk3 biblesync rarian gtkhtml libminizip appstream-glib yelp"
MAINTAINER="Tim Dickson"
EMAIL="dickson.tim@googlemail.com"