summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2020-04-15 23:54:58 +0200
committer Willy Sudiarto Raharjo2020-04-19 05:52:24 +0200
commita1d0533597fb5d3c423c23eb12a9d44b04282d54 (patch)
tree096a98f839482bb3a1019d9914a6537f89b8a18b
parent974bceb7acae65baac22d0872d20a451aabbf90a (diff)
downloadslackbuilds-a1d0533597fb5d3c423c23eb12a9d44b04282d54.tar.gz
libraries/SDL2: Updated for version 2.0.12, new maintainer.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/SDL2/README2
-rw-r--r--libraries/SDL2/SDL2.SlackBuild25
-rw-r--r--libraries/SDL2/SDL2.info4
3 files changed, 19 insertions, 12 deletions
diff --git a/libraries/SDL2/README b/libraries/SDL2/README
index 8e26524439..7fa6c9b740 100644
--- a/libraries/SDL2/README
+++ b/libraries/SDL2/README
@@ -1,3 +1,5 @@
+SDL2 (Simple DirectMedia Layer Version 2)
+
Simple DirectMedia Layer is a cross-platform development library designed to
provide low-level access to audio, keyboard, mouse, joystick, and graphics
hardware via OpenGL.
diff --git a/libraries/SDL2/SDL2.SlackBuild b/libraries/SDL2/SDL2.SlackBuild
index de90ba7d06..9172772783 100644
--- a/libraries/SDL2/SDL2.SlackBuild
+++ b/libraries/SDL2/SDL2.SlackBuild
@@ -3,7 +3,8 @@
# Slackware build script for SDL2
# Copyright 2013 Dugan Chen Canada
-# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020 Isaac Yu
+# Copyright 2020 B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,9 +24,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20200415 bkw:
+# - take over maintenance
+# - don't install static libSDL2.a
+# - don't copy CMakeLists.txt to doc dir (it's not documentation)
+# - don't copy useless INSTALL.txt to doc dir
+# - BUILD=2
+
PRGNAM=SDL2
VERSION=${VERSION:-2.0.12}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -64,11 +72,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
mkdir -p build
cd build
@@ -76,14 +81,14 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DBUILD_SHARED_LIBS=ON \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+rm -f INSTALL.txt CMakeLists.txt # don't copy these to doc dir
cp -a *.txt docs/*.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/SDL2/SDL2.info b/libraries/SDL2/SDL2.info
index 672541c1d8..a245b7b23a 100644
--- a/libraries/SDL2/SDL2.info
+++ b/libraries/SDL2/SDL2.info
@@ -6,5 +6,5 @@ MD5SUM="783b6f2df8ff02b19bb5ce492b99c8ff"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"