summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author orbea2020-03-12 14:29:22 +0100
committer Willy Sudiarto Raharjo2020-03-14 02:46:17 +0100
commit5147dd00814c41a66c6191984a5bfbdcf2dc3a30 (patch)
tree11c71437bb154fa86f2d66f2083ae03cdc19d706
parent45a7a5215837d0967e290a1c230776666d32bac8 (diff)
downloadslackbuilds-5147dd00814c41a66c6191984a5bfbdcf2dc3a30.tar.gz
python/pyewmh: Remove python2 support.
Signed-off-by: orbea <orbea@riseup.net>
-rw-r--r--python/pyewmh/README2
-rw-r--r--python/pyewmh/pyewmh.SlackBuild13
-rw-r--r--python/pyewmh/pyewmh.info2
3 files changed, 6 insertions, 11 deletions
diff --git a/python/pyewmh/README b/python/pyewmh/README
index 8259e9af80..0e162f676d 100644
--- a/python/pyewmh/README
+++ b/python/pyewmh/README
@@ -2,4 +2,4 @@ An implementation of EWMH (Extended Window Manager Hints) for python,
based on Xlib. It allows EWMH-compliant window managers (most modern
WMs) to be queried and controlled.
-Python3 is an optional dependency.
+python3 should be installed before any other dependencies.
diff --git a/python/pyewmh/pyewmh.SlackBuild b/python/pyewmh/pyewmh.SlackBuild
index 10c93a87cd..a2885d27e6 100644
--- a/python/pyewmh/pyewmh.SlackBuild
+++ b/python/pyewmh/pyewmh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyewmh
-# Copyright 2016-2018 Hunter Sezen California, USA
+# Copyright 2016-2018, 2020 Hunter Sezen California, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pyewmh
VERSION=${VERSION:-0.1.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -55,15 +55,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if python3 -c 'import sys' 2>/dev/null; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a -- *.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pyewmh/pyewmh.info b/python/pyewmh/pyewmh.info
index d3f836f070..5107294f8c 100644
--- a/python/pyewmh/pyewmh.info
+++ b/python/pyewmh/pyewmh.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/parkouss/pyewmh/archive/v0.1.6/pyewmh-0.1.6.tar.gz"
MD5SUM="9547049c458904e1083907c763e990d5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-xlib"
+REQUIRES="python3 python-xlib"
MAINTAINER="Hunter Sezen"
EMAIL="orbea@riseup.net"