summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2020-02-13 13:44:47 +0100
committer Willy Sudiarto Raharjo2020-02-15 03:51:02 +0100
commita5fda2a9eb2467888873d38b2e5a13b80770776c (patch)
tree9681744e255c5db0cc421f9a1122500bbf3f0cd3
parent25282197f1310877b6a7fa483e3197ec24d8b753 (diff)
downloadslackbuilds-a5fda2a9eb2467888873d38b2e5a13b80770776c.tar.gz
python/python-notify2: Added python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/python-notify2/python-notify2.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/python-notify2/python-notify2.SlackBuild b/python/python-notify2/python-notify2.SlackBuild
index 81fbc72fe7..847f3135da 100644
--- a/python/python-notify2/python-notify2.SlackBuild
+++ b/python/python-notify2/python-notify2.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-notify2
-# Copyright 2015-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2020 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=python-notify2
SRCNAM=$(echo $PRGNAM | cut -c8-14)
VERSION=${VERSION:-0.3.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true