summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2020-01-26 20:47:36 +0100
committer Willy Sudiarto Raharjo2020-02-01 03:00:35 +0100
commitff746b390580c04fb9b8b63220e943fbed05155f (patch)
tree4dde3395cef8e3f4034e53852b6b979046821620
parent13b54ae90c9a4cf35716b193c6f5294fe94e7328 (diff)
downloadslackbuilds-ff746b390580c04fb9b8b63220e943fbed05155f.tar.gz
python/psutil: Updated for version 5.6.7
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
-rw-r--r--python/psutil/README4
-rwxr-xr-x[-rw-r--r--]python/psutil/psutil.SlackBuild8
-rw-r--r--python/psutil/psutil.info6
3 files changed, 7 insertions, 11 deletions
diff --git a/python/psutil/README b/python/psutil/README
index 8ba3203e56..2e15f9464d 100644
--- a/python/psutil/README
+++ b/python/psutil/README
@@ -5,7 +5,3 @@ command line tools such as: ps, top, df, kill, free, lsof, netstat, ifconfig,
nice, ionice, iostat, iotop, uptime, pidof, tty, who, taskset, and pmap.
Optional dependencies: python3, mock and ipaddress
-
-To install python3 bindings run the slackbuild with PYTHON3=yes.
-
- # PYTHON3=yes ./psutil.SlackBuild
diff --git a/python/psutil/psutil.SlackBuild b/python/psutil/psutil.SlackBuild
index c37311562e..7432bbecb2 100644..100755
--- a/python/psutil/psutil.SlackBuild
+++ b/python/psutil/psutil.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for psutil
-# Copyright 2012-2019 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=psutil
-VERSION=${VERSION:-5.6.3}
+VERSION=${VERSION:-5.6.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,8 +57,8 @@ find -L . \
python setup.py install --root=$PKG
-# Install python3 bindings for psutil. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
+# Install python3 bindings for psutil.
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
diff --git a/python/psutil/psutil.info b/python/psutil/psutil.info
index e5cc2f3a79..f871822538 100644
--- a/python/psutil/psutil.info
+++ b/python/psutil/psutil.info
@@ -1,8 +1,8 @@
PRGNAM="psutil"
-VERSION="5.6.3"
+VERSION="5.6.7"
HOMEPAGE="https://github.com/giampaolo/psutil"
-DOWNLOAD="https://pypi.io/packages/source/p/psutil/psutil-5.6.3.tar.gz"
-MD5SUM="1bbc1788588cc3c2c461cd98a830ba72"
+DOWNLOAD="https://pypi.io/packages/source/p/psutil/psutil-5.6.7.tar.gz"
+MD5SUM="b2c94e0368fc6e6f237a7252f8e85ca2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""