summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2020-01-26 21:47:45 +0100
committer Willy Sudiarto Raharjo2020-02-01 03:00:35 +0100
commit3f4881e68ba57544f5e45f7bf5004e19b659d709 (patch)
treed8a0fbfe076543fa97488e8c5410ee5f5c4f356a
parent629343557046a4611d6fcfb55acb973ee1664153 (diff)
downloadslackbuilds-3f4881e68ba57544f5e45f7bf5004e19b659d709.tar.gz
python/python-sh: Autodetect python3
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
-rw-r--r--python/python-sh/README4
-rw-r--r--python/python-sh/python-sh.SlackBuild6
-rw-r--r--python/python-sh/python-sh.info2
3 files changed, 4 insertions, 8 deletions
diff --git a/python/python-sh/README b/python/python-sh/README
index e1c4d96069..c1002feea6 100644
--- a/python/python-sh/README
+++ b/python/python-sh/README
@@ -6,7 +6,3 @@ from sh import ifconfig
print(ifconfig("wlan0"))
Optional dependency: python3
-
-Note: Pass PYTHON3=yes to the slackbuild for pyhton 3 support.
-
- # PYTHON3="yes" ./python-sh.SlackBuild
diff --git a/python/python-sh/python-sh.SlackBuild b/python/python-sh/python-sh.SlackBuild
index 031a1c58b8..08c32303e2 100644
--- a/python/python-sh/python-sh.SlackBuild
+++ b/python/python-sh/python-sh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-sh
-# Copyright 2012-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-sh
VERSION=${VERSION:-1.12.14}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,7 +57,7 @@ find -L . \
python setup.py install --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
diff --git a/python/python-sh/python-sh.info b/python/python-sh/python-sh.info
index 7df7c7bc06..650d0a4a33 100644
--- a/python/python-sh/python-sh.info
+++ b/python/python-sh/python-sh.info
@@ -1,7 +1,7 @@
PRGNAM="python-sh"
VERSION="1.12.14"
HOMEPAGE="http://amoffat.github.com/sh/index.html"
-DOWNLOAD="https://files.pythonhosted.org/packages/7c/71/199d27d3e7e78bf448bcecae0105a1d5b29173ffd2bbadaa95a74c156770/sh-1.12.14.tar.gz"
+DOWNLOAD="https://pypi.io/packages/source/s/sh/sh-1.12.14.tar.gz"
MD5SUM="a8351aef25d25f707c17e0a7a6280251"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""