summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2020-01-04 20:53:43 +0100
committer Willy Sudiarto Raharjo2020-01-12 02:47:53 +0100
commita9af6452629b1b2216f4658be7f76ddda43341b3 (patch)
treeae9c475a566eb92b49d53cfedba036b0e7712283
parente67db9c492dec634e9edd63eff7278563cb3ffb9 (diff)
downloadslackbuilds-a9af6452629b1b2216f4658be7f76ddda43341b3.tar.gz
python/ipython: Rename executable to ipython2.
Python 2 is not at end of life, so default should be Python 3. Signed-off-by: Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-rw-r--r--python/ipython/ipython.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/python/ipython/ipython.SlackBuild b/python/ipython/ipython.SlackBuild
index 4af705431e..c2e72529af 100644
--- a/python/ipython/ipython.SlackBuild
+++ b/python/ipython/ipython.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=ipython
VERSION=${VERSION:-5.8.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,12 +57,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root="$PKG"
+python2 setup.py install --root="$PKG"
+rm $PKG/usr/bin/ipython
+rm $PKG/usr/bin/iptest*
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mv $PKG/usr/share/man $PKG/usr
+mkdir -p $PKG/usr/man/man1
+mv $PKG/usr/share/man/man1/$PRGNAM.1 $PKG/usr/man/man1/${PRGNAM}2.1
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done