summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Petar Petrov2020-01-05 11:35:29 +0100
committer Willy Sudiarto Raharjo2020-01-12 02:48:00 +0100
commit119599e8fc653eacadfbc2023a2ed7b055df5512 (patch)
tree82d14464cdc6f34e753703793aa33b141d1e1ea2
parentb15b607c96eee32c2f5026fcc21abbb72a1ca8bf (diff)
downloadslackbuilds-119599e8fc653eacadfbc2023a2ed7b055df5512.tar.gz
academic/PhyML: Updated for version 3.3.20190909.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--academic/PhyML/PhyML.SlackBuild35
-rw-r--r--academic/PhyML/PhyML.info6
2 files changed, 15 insertions, 26 deletions
diff --git a/academic/PhyML/PhyML.SlackBuild b/academic/PhyML/PhyML.SlackBuild
index cab8490604..bddb063c00 100644
--- a/academic/PhyML/PhyML.SlackBuild
+++ b/academic/PhyML/PhyML.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for PhyML
-# Copyright 2011-2019 Petar Petrov slackalaxy@gmail.com
+# Copyright 2011-2020 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,11 +25,12 @@
# Thanks to Niels Horn for some handy modifications and corrections.
PRGNAM=PhyML
-SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
-VERSION=${VERSION:-3.3.20190321}
+VERSION=${VERSION:-3.3.20190909}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -86,12 +87,9 @@ find -L . \
--build=$ARCH-slackware-linux
# Use our CFLAGS
-sed -i "/^CFLAGS/s/=/+=/" src/Makefile
-sed -i "/^CFLAGS/s/=/+=/" Makefile
+sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
make install DESTDIR=$PKG
# This is PhyML MPI. If you do not want it, comment the lines below. Then you do
@@ -108,12 +106,9 @@ make install DESTDIR=$PKG
--build=$ARCH-slackware-linux
# Use our CFLAGS
-sed -i "/^CFLAGS/s/=/+=/" src/Makefile
-sed -i "/^CFLAGS/s/=/+=/" Makefile
+sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
make install DESTDIR=$PKG
# This is Phyrex
@@ -129,12 +124,9 @@ make install DESTDIR=$PKG
--build=$ARCH-slackware-linux
# Use our CFLAGS
-sed -i "/^CFLAGS/s/=/+=/" src/Makefile
-sed -i "/^CFLAGS/s/=/+=/" Makefile
+sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
make install DESTDIR=$PKG
# This is PhyTime
@@ -150,12 +142,9 @@ make install DESTDIR=$PKG
--build=$ARCH-slackware-linux
# Use our CFLAGS
-sed -i "/^CFLAGS/s/=/+=/" src/Makefile
-sed -i "/^CFLAGS/s/=/+=/" Makefile
+sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/academic/PhyML/PhyML.info b/academic/PhyML/PhyML.info
index 14ae908fd7..f44eaca3de 100644
--- a/academic/PhyML/PhyML.info
+++ b/academic/PhyML/PhyML.info
@@ -1,8 +1,8 @@
PRGNAM="PhyML"
-VERSION="3.3.20190321"
+VERSION="3.3.20190909"
HOMEPAGE="https://github.com/stephaneguindon/phyml/"
-DOWNLOAD="https://github.com/stephaneguindon/phyml/archive/v3.3.20190321/phyml-3.3.20190321.tar.gz"
-MD5SUM="72d375be9c08ec34bedee126bfb141d9"
+DOWNLOAD="https://github.com/stephaneguindon/phyml/archive/v3.3.20190909/phyml-3.3.20190909.tar.gz"
+MD5SUM="35698ff61c1db57b238f5b2d2cc784b3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="openmpi"