summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Fernando Lopez Jr2019-10-19 05:50:55 +0200
committer Willy Sudiarto Raharjo2019-10-19 05:51:10 +0200
commit422b084d2633d9ac660f5748bfd827a520623604 (patch)
treebd5bf1f6e3550aa41f43d2e99f8473de52337ba7
parent3b5c54de4f42e914f779bb7b6166b4df3ac68c7b (diff)
downloadslackbuilds-422b084d2633d9ac660f5748bfd827a520623604.tar.gz
python/python-stdnum: Added (Python Module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-stdnum/README7
-rw-r--r--python/python-stdnum/python-stdnum.SlackBuild72
-rw-r--r--python/python-stdnum/python-stdnum.info10
-rw-r--r--python/python-stdnum/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/python/python-stdnum/README b/python/python-stdnum/README
new file mode 100644
index 0000000000..1e0fdcd189
--- /dev/null
+++ b/python/python-stdnum/README
@@ -0,0 +1,7 @@
+A Python module to parse, validate and reformat standard
+numbers and codes in different formats. It contains a
+large collection of number formats.
+
+Basically any number or code that has some validation
+mechanism available or some common formatting is eligible
+for inclusion in this library.
diff --git a/python/python-stdnum/python-stdnum.SlackBuild b/python/python-stdnum/python-stdnum.SlackBuild
new file mode 100644
index 0000000000..c2a7e6dc78
--- /dev/null
+++ b/python/python-stdnum/python-stdnum.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for python-stdnum
+
+# Copyright 2019 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-stdnum
+VERSION=${VERSION:-1.11}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING ChangeLog NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-stdnum/python-stdnum.info b/python/python-stdnum/python-stdnum.info
new file mode 100644
index 0000000000..be0c65e392
--- /dev/null
+++ b/python/python-stdnum/python-stdnum.info
@@ -0,0 +1,10 @@
+PRGNAM="python-stdnum"
+VERSION="1.11"
+HOMEPAGE="https://pypi.org/project/python-stdnum/"
+DOWNLOAD="https://files.pythonhosted.org/packages/03/3c/f7114365aef15de475a426a32adfdd7b5fc9f747e51fb404868c9b2ff45e/python-stdnum-1.11.tar.gz"
+MD5SUM="535da14cdc038f0a2739d1f012f63f91"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/python/python-stdnum/slack-desc b/python/python-stdnum/slack-desc
new file mode 100644
index 0000000000..6d80400581
--- /dev/null
+++ b/python/python-stdnum/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-stdnum: python-stdnum (Python Module)
+python-stdnum:
+python-stdnum: A Python module to parse, validate and reformat standard numbers and
+python-stdnum: codes in different formats. It contains a large collection of number
+python-stdnum: formats.
+python-stdnum:
+python-stdnum: Basically any number or code that has some validation mechanism
+python-stdnum: available or some common formatting is eligible for inclusion in this
+python-stdnum: library.
+python-stdnum: https://arthurdejong.org/python-stdnum/
+python-stdnum: