summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Javier Rojas2010-05-11 20:00:20 +0200
committer Robby Workman2010-05-11 20:00:20 +0200
commit683e2f47cc23503e04eae443f044272f78f333d3 (patch)
treeb31788ddf8039769c984236c99f4d078949b4c40
parentfc2864ac4dd468f3ff995fd48fe82493ec8aa228 (diff)
downloadslackbuilds-683e2f47cc23503e04eae443f044272f78f333d3.tar.gz
development/Jinja: Added to 12.0 repository
-rw-r--r--development/Jinja/Jinja.SlackBuild71
-rw-r--r--development/Jinja/Jinja.info8
-rw-r--r--development/Jinja/README6
-rw-r--r--development/Jinja/slack-desc19
4 files changed, 104 insertions, 0 deletions
diff --git a/development/Jinja/Jinja.SlackBuild b/development/Jinja/Jinja.SlackBuild
new file mode 100644
index 0000000000..4a11a3c70a
--- /dev/null
+++ b/development/Jinja/Jinja.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for Jinja
+
+# Copyright (c) 2008 Javier Rojas <jerojasro@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# If there's a good way to make this build with an ARCH other than
+# the one on which it's being built, please clue me in --rworkman
+
+PRGNAM=Jinja
+VERSION=1.2
+ARCH=$(uname -m)
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" python setup.py bdist
+tar xvf dist/$PRGNAM-$VERSION.linux-$ARCH.tar.gz -C $PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGES LICENSE TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mv $PKG/usr/docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+rmdir $PKG/usr/docs
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/Jinja/Jinja.info b/development/Jinja/Jinja.info
new file mode 100644
index 0000000000..f300f9841a
--- /dev/null
+++ b/development/Jinja/Jinja.info
@@ -0,0 +1,8 @@
+PRGNAM="Jinja"
+VERSION="1.2"
+HOMEPAGE="http://jinja.pocoo.org/"
+DOWNLOAD="http://pypi.python.org/packages/source/J/Jinja/Jinja-1.2.tar.gz"
+MD5SUM="1235a005ade00b213800ff1e798c0241"
+MAINTAINER="Javier Rojas"
+EMAIL="jerojasro@gmail.com"
+APPROVED="rworkman"
diff --git a/development/Jinja/README b/development/Jinja/README
new file mode 100644
index 0000000000..eb7ae62251
--- /dev/null
+++ b/development/Jinja/README
@@ -0,0 +1,6 @@
+Jinja is a sandboxed template engine written in pure Python licensed under the
+BSD license. It provides a Django-like non-XML syntax and compiles templates
+into executable python code. It's basically a combination of Django templates
+and python code.
+
+This requires the Python setuptools (pysetuptools at SlackBuilds.org).
diff --git a/development/Jinja/slack-desc b/development/Jinja/slack-desc
new file mode 100644
index 0000000000..d87fbdfb32
--- /dev/null
+++ b/development/Jinja/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler--------------------------------------------------------|
+Jinja: Jinja (Django template engine)
+Jinja:
+Jinja: Jinja is a sandboxed template engine written in pure Python licensed
+Jinja: under the BSD license. It provides a Django-like non-XML syntax and
+Jinja: compiles templates into executable python code. It's basically a
+Jinja: combination of Django templates and python code.
+Jinja:
+Jinja: Homepage: http://jinja.pocoo.org/
+Jinja:
+Jinja:
+Jinja: