summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-06-07 14:13:31 +0200
committer Willy Sudiarto Raharjo2019-06-09 00:33:15 +0200
commitcb5c065177e350f4d60de1417ee3f656b0666ad3 (patch)
tree617991abca7d87c9e2d7e43bb149cd409f316277
parentcacbae7fb85aa0dab99fa5528a5c38d5795f2eec (diff)
downloadslackbuilds-cb5c065177e350f4d60de1417ee3f656b0666ad3.tar.gz
python/python3-simplegeneric: Removed (merged with simplegeneric).
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
-rw-r--r--python/python3-simplegeneric/README3
-rw-r--r--python/python3-simplegeneric/python3-simplegeneric.SlackBuild70
-rw-r--r--python/python3-simplegeneric/python3-simplegeneric.info10
-rw-r--r--python/python3-simplegeneric/slack-desc19
4 files changed, 0 insertions, 102 deletions
diff --git a/python/python3-simplegeneric/README b/python/python3-simplegeneric/README
deleted file mode 100644
index 390479b2e8..0000000000
--- a/python/python3-simplegeneric/README
+++ /dev/null
@@ -1,3 +0,0 @@
-The simplegeneric module lets you define simple single-dispatch
-generic functions, akin to Python's built-in generic functions like
-len(), iter() and so on.
diff --git a/python/python3-simplegeneric/python3-simplegeneric.SlackBuild b/python/python3-simplegeneric/python3-simplegeneric.SlackBuild
deleted file mode 100644
index 188c796a8c..0000000000
--- a/python/python3-simplegeneric/python3-simplegeneric.SlackBuild
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-simplegeneric
-
-# Copyright 2012 Mikko Värri, Finland
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=simplegeneric
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-0.8.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-unzip $CWD/$SRCNAM-$VERSION.zip
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-simplegeneric/python3-simplegeneric.info b/python/python3-simplegeneric/python3-simplegeneric.info
deleted file mode 100644
index 13ecae5275..0000000000
--- a/python/python3-simplegeneric/python3-simplegeneric.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-simplegeneric"
-VERSION="0.8.1"
-HOMEPAGE="https://pypi.python.org/pypi/simplegeneric"
-DOWNLOAD="https://pypi.python.org/packages/source/s/simplegeneric/simplegeneric-0.8.1.zip"
-MD5SUM="f9c1fab00fd981be588fc32759f474e3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-simplegeneric/slack-desc b/python/python3-simplegeneric/slack-desc
deleted file mode 100644
index b3154bd9b2..0000000000
--- a/python/python3-simplegeneric/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-simplegeneric: python3-simplegeneric (Simple generic functions for Python 3)
-python3-simplegeneric:
-python3-simplegeneric: The simplegeneric module lets you define simple single-dispatch
-python3-simplegeneric: generic functions, akin to Python's built-in generic functions like
-python3-simplegeneric: len(), iter() and so on.
-python3-simplegeneric:
-python3-simplegeneric:
-python3-simplegeneric:
-python3-simplegeneric:
-python3-simplegeneric:
-python3-simplegeneric: