summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2019-06-03 04:09:05 +0200
committer Willy Sudiarto Raharjo2019-06-09 00:31:19 +0200
commit0f70df48ca143a2eb3604de9ed501db7fd659a82 (patch)
treedc21f599923d2bcd961c622da6ca66d5fae311be
parente4d7f1e0db82e71cae70434b3669d5c0f24e7a0a (diff)
downloadslackbuilds-0f70df48ca143a2eb3604de9ed501db7fd659a82.tar.gz
python/python3-pyserial: Removed (use pyserial).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-pyserial/README5
-rw-r--r--python/python3-pyserial/python3-pyserial.SlackBuild89
-rw-r--r--python/python3-pyserial/python3-pyserial.info10
-rw-r--r--python/python3-pyserial/slack-desc19
4 files changed, 0 insertions, 123 deletions
diff --git a/python/python3-pyserial/README b/python/python3-pyserial/README
deleted file mode 100644
index 09add54e81..0000000000
--- a/python/python3-pyserial/README
+++ /dev/null
@@ -1,5 +0,0 @@
-This module encapsulates the access for the serial port. It provides
-backends for Python3 running on Windows, OSX, Linux, BSD (possibly any
-POSIX compliant system) and IronPython.
-
-The module named "serial" automatically selects the appropriate backend.
diff --git a/python/python3-pyserial/python3-pyserial.SlackBuild b/python/python3-pyserial/python3-pyserial.SlackBuild
deleted file mode 100644
index a66d03b52c..0000000000
--- a/python/python3-pyserial/python3-pyserial.SlackBuild
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-pyserial
-
-# Originally written by Grissiom <chaos.proton@gmail.com>
-# Updated to 2.5_rc2 by Dustin Schnee <schnee72{at}gmail{dot}com>
-# Copyright (c) 2017 Cristiano Urban, Gonars, Italy
-# All rights reserved.
-# modified for python3 (c) 2018 Tim Dickson, Scotland
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python3-pyserial
-SRCPRGNAM=pyserial
-VERSION=${VERSION:-3.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCPRGNAM-$VERSION
-tar xvf $CWD/$SRCPRGNAM-$VERSION.tar.gz
-cd $SRCPRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-pyserial/python3-pyserial.info b/python/python3-pyserial/python3-pyserial.info
deleted file mode 100644
index 24d4e26025..0000000000
--- a/python/python3-pyserial/python3-pyserial.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-pyserial"
-VERSION="3.4"
-HOMEPAGE="https://github.com/pyserial/pyserial"
-DOWNLOAD="https://github.com/pyserial/pyserial/archive/v3.4/pyserial-3.4.tar.gz"
-MD5SUM="fc00727ed9cf3a31b7a296a4d42f6afc"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Tim Dickson"
-EMAIL="dickson.tim@googlemail.com"
diff --git a/python/python3-pyserial/slack-desc b/python/python3-pyserial/slack-desc
deleted file mode 100644
index 20afcf4686..0000000000
--- a/python/python3-pyserial/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-pyserial: python3-pyserial (python3 module for accessing the serial port)
-python3-pyserial:
-python3-pyserial: This module encapsulates the access for the serial port. It provides
-python3-pyserial: backends for Python running on Windows, OSX, Linux, BSD (possibly any
-python3-pyserial: POSIX compliant system) and IronPython.
-python3-pyserial:
-python3-pyserial: Homepage: https://github.com/pyserial/pyserial
-python3-pyserial:
-python3-pyserial:
-python3-pyserial:
-python3-pyserial: