summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2019-01-11 10:16:22 +0100
committer Willy Sudiarto Raharjo2019-01-12 00:58:34 +0100
commit6a0a778e77e6ce5ffdb9924c44d7f85019f342a3 (patch)
tree6e4df4715a2e244f5bbcb95434ca882719dde7f7
parentfde171b9aa1b96f45099112d7f872631609be04e (diff)
downloadslackbuilds-6a0a778e77e6ce5ffdb9924c44d7f85019f342a3.tar.gz
system/i2c-tools: Use a single make job, build python modules.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--system/i2c-tools/i2c-tools.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/system/i2c-tools/i2c-tools.SlackBuild b/system/i2c-tools/i2c-tools.SlackBuild
index a14c9608c8..37ab0c622b 100644
--- a/system/i2c-tools/i2c-tools.SlackBuild
+++ b/system/i2c-tools/i2c-tools.SlackBuild
@@ -83,8 +83,11 @@ sed -i \
-e "s|BUILD_STATIC_LIB\ ?=\ 1|BUILD_STATIC_LIB ?= 0|" \
Makefile
-make
+make -j1
make install DESTDIR=$PKG
+( cd py-smbus
+ python setup.py install --root=$PKG
+ if $(python3 -c 'import sys' 2>/dev/null); then python3 setup.py install --root=$PKG ; fi)
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true