summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author MDrights2019-01-09 00:40:25 +0100
committer Willy Sudiarto Raharjo2019-01-09 00:40:25 +0100
commit415181d2b997b0051e100b07fded6938083fd0e5 (patch)
tree9aefdaa9052d4e6f160eb7a7761f4d791a9d55ad
parentd86d9532b10513763e050ae71c12c498745394c4 (diff)
downloadslackbuilds-415181d2b997b0051e100b07fded6938083fd0e5.tar.gz
python/pysha3: Added (SHA-3 wrapper for Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pysha3/README5
-rw-r--r--python/pysha3/pysha3.SlackBuild76
-rw-r--r--python/pysha3/pysha3.info10
-rw-r--r--python/pysha3/slack-desc19
4 files changed, 110 insertions, 0 deletions
diff --git a/python/pysha3/README b/python/pysha3/README
new file mode 100644
index 0000000000..6fd5ef5649
--- /dev/null
+++ b/python/pysha3/README
@@ -0,0 +1,5 @@
+SHA-3 wrapper (keccak) for Python.
+
+The module is a standalone version of the SHA-3 module from Python 3.6.
+The code in sha3module.c has been modified to be compatible with Python 2.7 to 3.5.
+Python 2.6 and earlier are not supported.
diff --git a/python/pysha3/pysha3.SlackBuild b/python/pysha3/pysha3.SlackBuild
new file mode 100644
index 0000000000..6e71b9797e
--- /dev/null
+++ b/python/pysha3/pysha3.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+# Slackware build script for pysha3
+
+# Copyright 2019 MDrights <psychi2009@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pysha3
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="LICENSE TODO AUTHORS CHANGES README.rst"
+# html documentation is not built by default
+HTML=${HTML:-0}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --prefix=/usr --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pysha3/pysha3.info b/python/pysha3/pysha3.info
new file mode 100644
index 0000000000..9cd372ee37
--- /dev/null
+++ b/python/pysha3/pysha3.info
@@ -0,0 +1,10 @@
+PRGNAM="pysha3"
+VERSION="1.0.2"
+HOMEPAGE="https://github.com/tiran/pysha3"
+DOWNLOAD="https://files.pythonhosted.org/packages/73/bf/978d424ac6c9076d73b8fdc8ab8ad46f98af0c34669d736b1d83c758afee/pysha3-1.0.2.tar.gz"
+MD5SUM="59cd2db7a9988c1f3f6aee40145e0c96"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="MDrights"
+EMAIL="psychi2009@gmail.com"
diff --git a/python/pysha3/slack-desc b/python/pysha3/slack-desc
new file mode 100644
index 0000000000..47cf6dc2cf
--- /dev/null
+++ b/python/pysha3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pysha3: pysha3 (SHA-3 wrapper for Python)
+pysha3:
+pysha3: The module is a standalone version of the SHA-3 module from Python 3.6
+pysha3: Python 2.6 and earlier are not supported.
+pysha3:
+pysha3: Homepage: https://github.com/tiran/pysha3
+pysha3:
+pysha3:
+pysha3:
+pysha3:
+pysha3: