summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali2018-11-04 03:56:01 +0100
committer Willy Sudiarto Raharjo2018-11-10 01:48:10 +0100
commit02e5a1c05d728c9101d9d33165683c6f01e6d083 (patch)
tree95243e0e481874f096df8f33f8900767a66b050d
parent221fa30fceef4d52364600aed883f837e69af814 (diff)
downloadslackbuilds-02e5a1c05d728c9101d9d33165683c6f01e6d083.tar.gz
libraries/html5lib: Updated for version 1.0.1
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
-rw-r--r--libraries/html5lib/README2
-rw-r--r--libraries/html5lib/html5lib.SlackBuild15
-rw-r--r--libraries/html5lib/html5lib.info6
3 files changed, 14 insertions, 9 deletions
diff --git a/libraries/html5lib/README b/libraries/html5lib/README
index b27413631a..e97c619b21 100644
--- a/libraries/html5lib/README
+++ b/libraries/html5lib/README
@@ -8,3 +8,5 @@ major desktop web browsers.
Output is to a tree structure; the current release supports output
to DOM, ElementTree and lxml tree formats as well as a simple
custom format.
+
+Optional: datrie, python-chardet, lxml and genshi
diff --git a/libraries/html5lib/html5lib.SlackBuild b/libraries/html5lib/html5lib.SlackBuild
index e04b45d0b3..8195587882 100644
--- a/libraries/html5lib/html5lib.SlackBuild
+++ b/libraries/html5lib/html5lib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for html5lib
# Written by Šime Ramov <s@ramov.com>
-# Copyright 2017 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2017-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=html5lib
-VERSION=${VERSION:-0.999999999}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,13 +50,16 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/html5lib/html5lib.info b/libraries/html5lib/html5lib.info
index 566354e2fa..07cc7eabc8 100644
--- a/libraries/html5lib/html5lib.info
+++ b/libraries/html5lib/html5lib.info
@@ -1,8 +1,8 @@
PRGNAM="html5lib"
-VERSION="0.999999999"
+VERSION="1.0.1"
HOMEPAGE="https://github.com/html5lib/"
-DOWNLOAD="https://pypi.python.org/packages/17/ee/99e69cdcefc354e0c18ff2cc60aeeb5bfcc2e33f051bf0cc5526d790c445/html5lib-0.999999999.tar.gz"
-MD5SUM="8578e4e3a341436cb9743a9e4a299239"
+DOWNLOAD="https://pypi.io/packages/source/h/html5lib/html5lib-1.0.1.tar.gz"
+MD5SUM="942a0688d6bdf20d087c9805c40182ad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="six python-webencodings"