summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Christoph Willing2018-07-10 01:05:23 +0200
committer Willy Sudiarto Raharjo2018-07-14 01:55:52 +0200
commit00f17c4de9a2e01cd8d699703e9b56e2fd618427 (patch)
tree0e20bddb37e667d5ffc3ad690275d141bd380e84
parent79d4ae2349af13f4cb4c3a2d83bee81bdcb37102 (diff)
downloadslackbuilds-00f17c4de9a2e01cd8d699703e9b56e2fd618427.tar.gz
development/dkms: Updated for version 2.6.1 + new maintainer
Signed-off-by: Christoph Willing <chris.willing@linux.com>
-rw-r--r--development/dkms/Makefile_mktemp.diff (renamed from development/dkms/patches/Makefile_mktemp.diff)12
-rw-r--r--development/dkms/README11
-rw-r--r--development/dkms/dkms.SlackBuild6
-rw-r--r--development/dkms/dkms.info10
4 files changed, 26 insertions, 13 deletions
diff --git a/development/dkms/patches/Makefile_mktemp.diff b/development/dkms/Makefile_mktemp.diff
index 81cea13e84..783447ab7b 100644
--- a/development/dkms/patches/Makefile_mktemp.diff
+++ b/development/dkms/Makefile_mktemp.diff
@@ -1,6 +1,6 @@
---- Makefile.orig 2012-11-03 21:13:55.065215509 +0100
-+++ Makefile 2012-11-03 21:14:13.244222002 +0100
-@@ -90,7 +90,7 @@
+--- Makefile.orig 2018-04-26 01:56:48.000000000 +1000
++++ Makefile 2018-07-09 23:29:27.236000000 +1000
+@@ -97,7 +97,7 @@
$(TARBALL):
mkdir -p $(deb_destdir)
@@ -9,16 +9,16 @@
cp -a ../$(RELEASE_NAME) $${tmp_dir}/$(RELEASE_STRING) ; \
sed -e "s/\[INSERT_VERSION_HERE\]/$(RELEASE_VERSION)/" dkms > $${tmp_dir}/$(RELEASE_STRING)/dkms ; \
sed -e "s/\[INSERT_VERSION_HERE\]/$(RELEASE_VERSION)/" dkms.spec > $${tmp_dir}/$(RELEASE_STRING)/dkms.spec ; \
-@@ -107,7 +107,7 @@
+@@ -114,7 +114,7 @@
rpm: $(TARBALL) dkms.spec
- tmp_dir=`mktemp -d --tmpdir dkms.XXXXXXXX` ; \
+ tmp_dir=`mktemp -d -t dkms.XXXXXXXX` ; \
+ echo $(tmp_dir); \
mkdir -p $${tmp_dir}/{BUILD,RPMS,SRPMS,SPECS,SOURCES} ; \
cp $(TARBALL) $${tmp_dir}/SOURCES ; \
- sed "s/\[INSERT_VERSION_HERE\]/$(RELEASE_VERSION)/" dkms.spec > $${tmp_dir}/SPECS/dkms.spec ; \
-@@ -131,7 +131,7 @@
+@@ -139,7 +139,7 @@
cd -
debs:
diff --git a/development/dkms/README b/development/dkms/README
index baf8553d25..56098a14a0 100644
--- a/development/dkms/README
+++ b/development/dkms/README
@@ -1 +1,12 @@
Helper script for creating kernel modules.
+
+To facilitate automatic rebuilding of modules at reboot after
+installation of a new kernel version, the following code should be
+added near the beginning of the file /etc/rc.d/rc.modules.local
+
+# Enable DKMS module rebuilding
+if [ -x /usr/lib/dkms/dkms_autoinstaller ]; then
+ echo "Running DKMS autoinstaller"
+ /usr/lib/dkms/dkms_autoinstaller start
+fi
+
diff --git a/development/dkms/dkms.SlackBuild b/development/dkms/dkms.SlackBuild
index 9d9dea1c26..3f563ca45a 100644
--- a/development/dkms/dkms.SlackBuild
+++ b/development/dkms/dkms.SlackBuild
@@ -2,6 +2,8 @@
# Copyright (c) 2012-2017 LEVAI Daniel
# All rights reserved.
+# Copyright (c) 2018 Christoph Willing Brisbane, Australia
+# All rights reserved.
#
# * Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
@@ -24,7 +26,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=dkms
-VERSION=${VERSION:-2.4.0}
+VERSION=${VERSION:-2.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,7 +72,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch --strip=0 --quiet < $CWD/patches/Makefile_mktemp.diff
+patch -p0 < $CWD/Makefile_mktemp.diff
CFLAGS="$SLKCFLAGS" make install DESTDIR=$PKG
mv $PKG/usr/share/man $PKG/usr/man
diff --git a/development/dkms/dkms.info b/development/dkms/dkms.info
index 2c07307619..f2b5d680dc 100644
--- a/development/dkms/dkms.info
+++ b/development/dkms/dkms.info
@@ -1,10 +1,10 @@
PRGNAM="dkms"
-VERSION="2.4.0"
+VERSION="2.6.1"
HOMEPAGE="https://github.com/dell/dkms"
-DOWNLOAD="https://github.com/dell/dkms/archive/v2.4.0/dkms-2.4.0.tar.gz"
-MD5SUM="d2e74dd79086c564a924b5763794091b"
+DOWNLOAD="https://github.com/dell/dkms/archive/v2.6.1/dkms-2.6.1.tar.gz"
+MD5SUM="742fc7ece11a0808638a0f1e184f2069"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="LEVAI Daniel"
-EMAIL="leva@ecentrum.hu"
+MAINTAINER="Christoph Willing"
+EMAIL="chris.willing@linux.com"