summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-06-10 17:19:54 +0200
committer David Spencer2018-06-14 02:15:14 +0200
commit578baaffa1143b0de33a118f382811848fdd711c (patch)
tree65cb3d0b927638ad0bf3ff7f5d9e2a5c58bcbe2c
parent43a9f23ea8f556053c2fd2a53c9f00b4b82f05d4 (diff)
downloadslackbuilds-578baaffa1143b0de33a118f382811848fdd711c.tar.gz
gis/pointcloud: Updated for version 1.1.0.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
-rw-r--r--gis/pointcloud/pointcloud.SlackBuild32
-rw-r--r--gis/pointcloud/pointcloud.info6
-rw-r--r--gis/pointcloud/postgresql9.5.patch19
3 files changed, 14 insertions, 43 deletions
diff --git a/gis/pointcloud/pointcloud.SlackBuild b/gis/pointcloud/pointcloud.SlackBuild
index 35a4da9a59..af26628e46 100644
--- a/gis/pointcloud/pointcloud.SlackBuild
+++ b/gis/pointcloud/pointcloud.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pointcloud
-# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2013-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pointcloud
-VERSION=${VERSION:-1.0.1}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,25 +69,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Upstream commit
-# please remove it on next release
-patch -p1 < $CWD/postgresql9.5.patch
-
-sed -i "s/cppflags/cflags/" CMakeLists.txt
-sed -i "s/CPPFLAGS/CFLAGS/" CMakeLists.txt
-sed -i "s/CPPFLAGS/CFLAGS/" pgsql/CMakeLists.txt
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DWITH_TESTS=FALSE \
- ..
- make install DESTDIR=$PKG
-cd ..
+./autogen.sh
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --build=$ARCH-slackware-linux
+make
+make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/gis/pointcloud/pointcloud.info b/gis/pointcloud/pointcloud.info
index 6faae1c927..e2dd8907ef 100644
--- a/gis/pointcloud/pointcloud.info
+++ b/gis/pointcloud/pointcloud.info
@@ -1,8 +1,8 @@
PRGNAM="pointcloud"
-VERSION="1.0.1"
+VERSION="1.1.0"
HOMEPAGE="https://github.com/pramsey/pointcloud"
-DOWNLOAD="https://github.com/pramsey/pointcloud/archive/v1.0.1/pointcloud-1.0.1.tar.gz"
-MD5SUM="cceb8ae6985fc7fa5c5bf74ec412da68"
+DOWNLOAD="https://github.com/pramsey/pointcloud/archive/v1.1.0/pointcloud-1.1.0.tar.gz"
+MD5SUM="6cddad6a0ea841d9ed96465bb82a5448"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="postgresql"
diff --git a/gis/pointcloud/postgresql9.5.patch b/gis/pointcloud/postgresql9.5.patch
deleted file mode 100644
index a1c21765a7..0000000000
--- a/gis/pointcloud/postgresql9.5.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- pointcloud-1.0.1/pgsql/pc_access.c.orig 2016-02-07 08:01:10.553181345 +0700
-+++ pointcloud-1.0.1/pgsql/pc_access.c 2016-02-07 08:01:39.528225276 +0700
-@@ -313,15 +313,7 @@
- (errcode(ERRCODE_INVALID_PARAMETER_VALUE),
- errmsg("could not determine input data type")));
-
-- if (fcinfo->context && IsA(fcinfo->context, AggState))
-- {
-- aggcontext = ((AggState *) fcinfo->context)->aggcontext;
-- }
-- else if (fcinfo->context && IsA(fcinfo->context, WindowAggState))
-- {
-- aggcontext = ((WindowAggState *) fcinfo->context)->aggcontext;
-- }
-- else
-+ if ( ! AggCheckCallContext(fcinfo, &aggcontext) )
- {
- /* cannot be called directly because of dummy-type argument */
- elog(ERROR, "pointcloud_agg_transfn called in non-aggregate context");