summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Thibaut Notteboom2018-05-29 03:29:45 +0200
committer Willy Sudiarto Raharjo2018-05-29 03:29:45 +0200
commit483f9cfd67aba14b8aac3eb8c948a03a6ab7884b (patch)
tree68e7ca092ad0960d7ec2e75b7178ac9e5e87bb8f
parent4ab7b40454eff85d57dca5ac94dbf42cbefd0280 (diff)
downloadslackbuilds-483f9cfd67aba14b8aac3eb8c948a03a6ab7884b.tar.gz
python/python-mysqlclient: Added (Fork of MySQL-python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-mysqlclient/README4
-rw-r--r--python/python-mysqlclient/python-mysqlclient.SlackBuild90
-rw-r--r--python/python-mysqlclient/python-mysqlclient.info10
-rw-r--r--python/python-mysqlclient/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/python/python-mysqlclient/README b/python/python-mysqlclient/README
new file mode 100644
index 0000000000..0aaee3399d
--- /dev/null
+++ b/python/python-mysqlclient/README
@@ -0,0 +1,4 @@
+This is a fork of MySQL-python. This project adds Python 3 support and
+bug fixes.
+
+python3 is an optional dependency (autodetected).
diff --git a/python/python-mysqlclient/python-mysqlclient.SlackBuild b/python/python-mysqlclient/python-mysqlclient.SlackBuild
new file mode 100644
index 0000000000..b0831ed032
--- /dev/null
+++ b/python/python-mysqlclient/python-mysqlclient.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for python-mysqlclient
+
+# Copyright 2018 Thibaut Notteboom, Paris, FRANCE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-mysqlclient
+VERSION=${VERSION:-1.3.12}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=mysqlclient
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-python-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-python-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/ HISTORY.rst INSTALL.rst LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-mysqlclient/python-mysqlclient.info b/python/python-mysqlclient/python-mysqlclient.info
new file mode 100644
index 0000000000..6a34156443
--- /dev/null
+++ b/python/python-mysqlclient/python-mysqlclient.info
@@ -0,0 +1,10 @@
+PRGNAM="python-mysqlclient"
+VERSION="1.3.12"
+HOMEPAGE="https://github.com/PyMySQL/mysqlclient-python/"
+DOWNLOAD="https://github.com/PyMySQL/mysqlclient-python/archive/1.3.12/mysqlclient-1.3.12.tar.gz"
+MD5SUM="006ff8a8d748ed2ab37c745e7cf6bedd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Thibaut Notteboom"
+EMAIL="thibaut.notteboom@gmail.com"
diff --git a/python/python-mysqlclient/slack-desc b/python/python-mysqlclient/slack-desc
new file mode 100644
index 0000000000..cef7419553
--- /dev/null
+++ b/python/python-mysqlclient/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-mysqlclient: python-mysqlclient (Fork of MySQL-python with support for Python 3)
+python-mysqlclient:
+python-mysqlclient: This is a fork of MySQL-python. This project adds Python 3 support and
+python-mysqlclient: bug fixes.
+python-mysqlclient:
+python-mysqlclient:
+python-mysqlclient:
+python-mysqlclient:
+python-mysqlclient:
+python-mysqlclient:
+python-mysqlclient: