summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-04-13 07:00:20 +0200
committer Willy Sudiarto Raharjo2018-04-14 02:06:34 +0200
commitf93aec18a96c88099a67412f3a3635785f07c6a8 (patch)
tree66b88d4961c7b63c846f98d06ec4add5f06eacb8
parent48263557b3d05ff9208da03175975bccc101c076 (diff)
downloadslackbuilds-f93aec18a96c88099a67412f3a3635785f07c6a8.tar.gz
gis/Shapely: Script cleanup.
-rw-r--r--gis/Shapely/Shapely.SlackBuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/gis/Shapely/Shapely.SlackBuild b/gis/Shapely/Shapely.SlackBuild
index d9de959e2f..86856a927d 100644
--- a/gis/Shapely/Shapely.SlackBuild
+++ b/gis/Shapely/Shapely.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Shapely
-# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2013-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -64,10 +64,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# remove unnecessary .pxi file
sed -i "s/data_files\s*=.*/data_files = [],/g" setup.py
@@ -77,11 +77,13 @@ if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.txt CREDITS.txt LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.txt CREDITS.txt LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install