summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author wigums2018-04-03 02:40:47 +0200
committer Willy Sudiarto Raharjo2018-04-07 03:13:10 +0200
commit787e62687077cfdf805c2cb721c37f68672bc2ac (patch)
tree8ef169650774ac13f30b7397143a892193b989a3
parent1d2ffe3ab6e927ad3814eb2689a0c3104b547966 (diff)
downloadslackbuilds-787e62687077cfdf805c2cb721c37f68672bc2ac.tar.gz
system/bbqsql: Added (A Blind SQL Injection Exploitation Tool).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--system/bbqsql/README7
-rw-r--r--system/bbqsql/bbqsql.SlackBuild68
-rw-r--r--system/bbqsql/bbqsql.info10
-rw-r--r--system/bbqsql/slack-desc19
4 files changed, 104 insertions, 0 deletions
diff --git a/system/bbqsql/README b/system/bbqsql/README
new file mode 100644
index 0000000000..23a751cbdc
--- /dev/null
+++ b/system/bbqsql/README
@@ -0,0 +1,7 @@
+BBQSQL is a blind SQL injection framework written in Python. It is
+extremely useful when attacking tricky SQL injection vulnerabilities.
+BBQSQL is also a semi-automatic tool, allowing quite a bit of
+customization for those hard to trigger SQL injection findings. The
+tool is built to be database agnostic and is extremely versatile. It
+also has an intuitive UI to make setting up attacks much easier. Python
+gevent is also implemented, making BBQSQL extremely fast.
diff --git a/system/bbqsql/bbqsql.SlackBuild b/system/bbqsql/bbqsql.SlackBuild
new file mode 100644
index 0000000000..986a2d7a82
--- /dev/null
+++ b/system/bbqsql/bbqsql.SlackBuild
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# Slackware build script for bbqsql
+
+# Written by wigums (wigums@protonmail.com)
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=bbqsql
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/bbqsql/bbqsql.info b/system/bbqsql/bbqsql.info
new file mode 100644
index 0000000000..5c353f9d83
--- /dev/null
+++ b/system/bbqsql/bbqsql.info
@@ -0,0 +1,10 @@
+PRGNAM="bbqsql"
+VERSION="1.1"
+HOMEPAGE="https://github.com/Neohapsis/bbqsql/"
+DOWNLOAD="https://github.com/Neohapsis/bbqsql/archive/v1.1/bbqsql-1.1.tar.gz"
+MD5SUM="53c7018a59118a6d82a81967ab646467"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="wigums"
+EMAIL="pioneer22675@gmail.com"
diff --git a/system/bbqsql/slack-desc b/system/bbqsql/slack-desc
new file mode 100644
index 0000000000..e60a707948
--- /dev/null
+++ b/system/bbqsql/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+bbqsql: bbqsql (A Blind SQL Injection Exploitation Tool)
+bbqsql:
+bbqsql: BBQSQL is a blind SQL injection framework written in Python.
+bbqsql: The tool is built to be database agnostic and is extremely versatile.
+bbqsql:
+bbqsql: Blind SQL injection can be a pain to exploit. When the available tools
+bbqsql: work well, but when they don't you have to write something custom.
+bbqsql: This is time-consuming and tedious. BBQSQL can help you address those
+bbqsql: issues.
+bbqsql:
+bbqsql: