summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Michael Heras2018-02-23 00:34:37 +0100
committer Willy Sudiarto Raharjo2018-02-24 00:55:39 +0100
commitbd855121b4636a055c830631cd0c2465183cc415 (patch)
tree6f9e6ac2ecc75fb2e15dbbd6f840825f5ee53ba3
parent1a996aa2859eb6ad7b83c808733c98d784c8b15f (diff)
downloadslackbuilds-bd855121b4636a055c830631cd0c2465183cc415.tar.gz
desktop/wmcpuwatch: Added (form of wmmon).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/wmcpuwatch/README1
-rw-r--r--desktop/wmcpuwatch/slack-desc19
-rw-r--r--desktop/wmcpuwatch/wmcpuwatch.SlackBuild114
-rw-r--r--desktop/wmcpuwatch/wmcpuwatch.info10
4 files changed, 144 insertions, 0 deletions
diff --git a/desktop/wmcpuwatch/README b/desktop/wmcpuwatch/README
new file mode 100644
index 0000000000..85c3b97977
--- /dev/null
+++ b/desktop/wmcpuwatch/README
@@ -0,0 +1 @@
+wmcpuwatch aims to show the load of every logical CPU on the system.
diff --git a/desktop/wmcpuwatch/slack-desc b/desktop/wmcpuwatch/slack-desc
new file mode 100644
index 0000000000..baf1d1e8ea
--- /dev/null
+++ b/desktop/wmcpuwatch/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+wmcpuwatch: wmcpuwatch (form of wmmon)
+wmcpuwatch:
+wmcpuwatch: It is a fork of wmmon. wmmon shows the load of up to 10 CPUs. With a
+wmcpuwatch: little tweaking it is possible to show 12 with wmmon, but when in 2017
+wmcpuwatch: Intel announced a 18 core CPU (and AMD was with their Ryzen even
+wmcpuwatch: earlier), there was time for a new dockapp.
+wmcpuwatch:
+wmcpuwatch: wmcpuwatch now shows the load of all CPUs in the lower frame which
+wmcpuwatch: allows 40 CPUs at max.
+wmcpuwatch:
+wmcpuwatch: https://bitbucket.org/StarFire/wmcpuwatch
diff --git a/desktop/wmcpuwatch/wmcpuwatch.SlackBuild b/desktop/wmcpuwatch/wmcpuwatch.SlackBuild
new file mode 100644
index 0000000000..7c3757ea91
--- /dev/null
+++ b/desktop/wmcpuwatch/wmcpuwatch.SlackBuild
@@ -0,0 +1,114 @@
+#!/bin/sh
+
+# Slackware build script for <wmcpuwatch>
+
+# Copyright <2018> <Michael Heras>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=wmcpuwatch
+VERSION=${VERSION:-0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i '
+/cmake_minimum_required(VERSION 3.9)/{
+ x
+ # add a dot to the hold space
+ s/$/./
+ # #dots==#desired?
+ /^.\{1\}$/{
+ # do the replacement action
+ x
+ s:cmake_minimum_required(VERSION 3.9):cmake_minimum_required(VERSION 3.5):
+ x
+ }
+ x
+}
+' $PWD/CMakeLists.txt
+
+sed -i "s|share/man/man1|man/man1|g" CMakeLists.txt
+sed -i "s|share/doc/\${CMAKE_PROJECT_NAME}|doc/$PRGNAM-$VERSION|g" doc/CMakeLists.txt
+
+cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release .
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm -rf $PKG/usr/share/doc
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/wmcpuwatch/wmcpuwatch.info b/desktop/wmcpuwatch/wmcpuwatch.info
new file mode 100644
index 0000000000..2f077a29bd
--- /dev/null
+++ b/desktop/wmcpuwatch/wmcpuwatch.info
@@ -0,0 +1,10 @@
+PRGNAM="wmcpuwatch"
+VERSION="0.2"
+HOMEPAGE="https://bitbucket.org/StarFire/wmcpuwatch"
+DOWNLOAD="https://bitbucket.org/StarFire/wmcpuwatch/downloads/wmcpuwatch-0.2.tar.bz2"
+MD5SUM="bf6081e07775febe6032c81d6525ad14"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libdockapp"
+MAINTAINER="Michael Heras"
+EMAIL="userxbw@gmail.com"