summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Azure Zanculmarktum2017-11-23 11:49:35 +0100
committer David Spencer2017-11-23 11:49:35 +0100
commit5a04803776302a37bdfd9d7a7c9d283509cfede3 (patch)
tree3a09846bf99ec7f3eec7da4fefe8bce041ec6945
parentdbca34bb4b41900683e6564aef980c55314b9c32 (diff)
downloadslackbuilds-5a04803776302a37bdfd9d7a7c9d283509cfede3.tar.gz
python/pywal: Added (generate and change colorschemes on the fly).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--python/pywal/README9
-rw-r--r--python/pywal/pywal.SlackBuild85
-rw-r--r--python/pywal/pywal.info10
-rw-r--r--python/pywal/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/python/pywal/README b/python/pywal/README
new file mode 100644
index 0000000000..22a8b444df
--- /dev/null
+++ b/python/pywal/README
@@ -0,0 +1,9 @@
+wal is a script that takes an image (or a directory of images),
+generates a colorscheme (using imagemagick) and then changes all of your
+open terminal's colors to the new colorscheme on the fly. wal then
+caches each generated colorscheme so that cycling through wallpapers
+while changing colorschemes is instantaneous.
+
+Dependencies for wallpaper setting (select one):
+ feh, nitrogen, hsetroot, bgs (not available at SBo), habak (not
+ available at SBo), or any desktop environment.
diff --git a/python/pywal/pywal.SlackBuild b/python/pywal/pywal.SlackBuild
new file mode 100644
index 0000000000..94ca1cbfef
--- /dev/null
+++ b/python/pywal/pywal.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for pywal
+
+# Copyright 2017 Azure Zanculmarktum <zanculmarktum@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pywal
+VERSION=${VERSION:-0.7.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.md MANIFEST.in README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pywal/pywal.info b/python/pywal/pywal.info
new file mode 100644
index 0000000000..118fdc785a
--- /dev/null
+++ b/python/pywal/pywal.info
@@ -0,0 +1,10 @@
+PRGNAM="pywal"
+VERSION="0.7.1"
+HOMEPAGE="https://github.com/dylanaraps/pywal"
+DOWNLOAD="https://pypi.python.org/packages/29/75/2e77167dd3cf1d950423677a5c42b729814b9d4f134e67f436cb7ed394dd/pywal-0.7.1.tar.gz"
+MD5SUM="ab8c8ac858a7a45a1c66f7c0290d57d1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Azure Zanculmarktum"
+EMAIL="zanculmarktum@gmail.com"
diff --git a/python/pywal/slack-desc b/python/pywal/slack-desc
new file mode 100644
index 0000000000..db8b7331f4
--- /dev/null
+++ b/python/pywal/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pywal: pywal (generate and change colorschemes on the fly)
+pywal:
+pywal: wal is a script that takes an image (or a directory of images),
+pywal: generates a colorscheme (using imagemagick) and then changes all of
+pywal: your open terminal's colors to the new colorscheme on the fly. wal then
+pywal: caches each generated colorscheme so that cycling through wallpapers
+pywal: while changing colorschemes is instantaneous.
+pywal:
+pywal:
+pywal:
+pywal: