summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Petar Petrov2017-10-07 17:05:35 +0200
committer Willy Sudiarto Raharjo2017-10-11 01:19:45 +0200
commit0a3c56553633f2af5933a6a86ba231bb27588c97 (patch)
tree2d0079e59bd67ee1096c926ee4053b97b6dfaa53
parent8ca05dd513e5dc9718f8956befa032968ee5c468 (diff)
downloadslackbuilds-0a3c56553633f2af5933a6a86ba231bb27588c97.tar.gz
academic/PhyML: Updated for version 3.3.20170530.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--academic/PhyML/PhyML.SlackBuild41
-rw-r--r--academic/PhyML/PhyML.info6
-rw-r--r--academic/PhyML/README11
-rw-r--r--academic/PhyML/slack-desc2
4 files changed, 34 insertions, 26 deletions
diff --git a/academic/PhyML/PhyML.SlackBuild b/academic/PhyML/PhyML.SlackBuild
index d4b3d67cae..d82f9370f5 100644
--- a/academic/PhyML/PhyML.SlackBuild
+++ b/academic/PhyML/PhyML.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for PhyML
-# Copyright 2011-2016 Petar Petrov slackalaxy@gmail.com
+# Copyright 2011-2017 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,13 +25,11 @@
# Thanks to Niels Horn for some handy modifications and corrections.
PRGNAM=PhyML
-VERSION=${VERSION:-3.2.20160530}
+SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
+VERSION=${VERSION:-3.3.20170530}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
-SRCVER=3.2.20160530
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -64,15 +62,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$SRCVER
-
-if [ -e $CWD/v${SRCVER}.tar.gz ]; then
- tar xvf $CWD/v${SRCVER}.tar.gz
-else
- tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
-fi
-
-cd $SRCNAM-$SRCVER
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -145,6 +137,27 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
+# This is PhyTime
+./autogen.sh
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --enable-phytime \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+# Use our CFLAGS
+sed -i "/^CFLAGS/s/=/+=/" src/Makefile
+sed -i "/^CFLAGS/s/=/+=/" Makefile
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
+make install DESTDIR=$PKG
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/academic/PhyML/PhyML.info b/academic/PhyML/PhyML.info
index 739d1befc0..3a44d2b2b0 100644
--- a/academic/PhyML/PhyML.info
+++ b/academic/PhyML/PhyML.info
@@ -1,8 +1,8 @@
PRGNAM="PhyML"
-VERSION="3.2.20160530"
+VERSION="3.3.20170530"
HOMEPAGE="https://github.com/stephaneguindon/phyml/"
-DOWNLOAD="https://github.com/stephaneguindon/phyml/archive/v3.2.20160530.tar.gz"
-MD5SUM="7a4689e2de3ac9efd7586980b07331f0"
+DOWNLOAD="https://github.com/stephaneguindon/phyml/archive/v3.3.20170530/phyml-3.3.20170530.tar.gz"
+MD5SUM="8801c23dbdb295b6bbcd417f0010bb6a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="openmpi"
diff --git a/academic/PhyML/README b/academic/PhyML/README
index fd66cda123..b6ce38f0bd 100644
--- a/academic/PhyML/README
+++ b/academic/PhyML/README
@@ -9,16 +9,11 @@ It also implements two methods to evaluate branch supports in a sound
statistical framework (the non-parametric bootstrap and the
approximate likelihood ratio test).
-NOTE 1: This also builds Phyrex and the MPI (using multiple processors)
-version of PhyML. The executable of the latter is called phyml-mpi and
-requires openmpi. If you do not want them to be built in the package,
+This also builds MPI (using multiple processors) version of PhyML, which
+requires 'openmpi'. Other additional programs built by the script are
+Phyrex and PhyTime. If you do not want them to be built in the package,
check the SlackBuild script.
-NOTE 2: PhyTime used to be part of the PhyML package. However, PhyTime
-from the latest releases of PhyML does not build anymore. meanwhile,
-PhyTime is available separately, which installs the latest version that
-builds.
-
For details and citation
New Algorithms and Methods to Estimate Maximum-Likelihood
Phylogenies: Assessing the Performance of PhyML 3.0. Guindon S.,
diff --git a/academic/PhyML/slack-desc b/academic/PhyML/slack-desc
index ae498120bb..e03cd2812c 100644
--- a/academic/PhyML/slack-desc
+++ b/academic/PhyML/slack-desc
@@ -14,6 +14,6 @@ PhyML: wide range of options that were designed to facilitate standard
PhyML: phylogenetic analyses.
PhyML:
PhyML: Home: http://code.google.com/p/phyml/
-PhyML: References: /usr/doc/PhyML-3.2.20160530/References
+PhyML: References: /usr/doc/PhyML-3.3.20170530/References
PhyML:
PhyML: