summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Audrius Kažukauskas2017-08-20 14:23:23 +0200
committer Willy Sudiarto Raharjo2017-08-26 02:20:44 +0200
commitedaed3d07af00bdf62aa1644d84e3d4ff23c2b15 (patch)
treea0c6f5a0b647edcc8066b86ba0a92f75a1da6f65
parent335158d78e556a162674e1229784e77fa86c21c9 (diff)
downloadslackbuilds-edaed3d07af00bdf62aa1644d84e3d4ff23c2b15.tar.gz
python/python3: Updated for version 3.6.2.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
-rw-r--r--python/python3/patches/python3.no-static-library.diff14
-rw-r--r--python/python3/patches/python3.x86_64.diff54
-rw-r--r--python/python3/python3.SlackBuild2
-rw-r--r--python/python3/python3.info6
4 files changed, 38 insertions, 38 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index 2821ca79d0..cbdc676f7a 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
---- Python-3.6.0.orig/Makefile.pre.in 2016-12-23 04:21:21.000000000 +0200
-+++ Python-3.6.0/Makefile.pre.in 2016-12-27 22:50:14.139741226 +0200
-@@ -564,7 +564,7 @@
+diff -uar Python-3.6.2.orig/Makefile.pre.in Python-3.6.2/Makefile.pre.in
+--- Python-3.6.2.orig/Makefile.pre.in 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Makefile.pre.in 2017-08-20 15:03:55.591112188 +0300
+@@ -533,7 +533,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
@@ -10,7 +10,7 @@ diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -609,18 +609,6 @@
+@@ -578,18 +578,6 @@
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -710,7 +698,7 @@
+@@ -679,7 +667,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1388,18 +1376,6 @@
+@@ -1391,18 +1379,6 @@
else true; \
fi; \
done
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 182fc62932..cf2c46aa5f 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.6.1.orig/Lib/distutils/command/install.py Python-3.6.1/Lib/distutils/command/install.py
---- Python-3.6.1.orig/Lib/distutils/command/install.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Lib/distutils/command/install.py 2017-03-22 21:42:23.915962369 +0200
+diff -uar Python-3.6.2.orig/Lib/distutils/command/install.py Python-3.6.2/Lib/distutils/command/install.py
+--- Python-3.6.2.orig/Lib/distutils/command/install.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Lib/distutils/command/install.py 2017-08-20 15:10:41.653336676 +0300
@@ -29,15 +29,15 @@
INSTALL_SCHEMES = {
@@ -21,10 +21,10 @@ diff -uar Python-3.6.1.orig/Lib/distutils/command/install.py Python-3.6.1/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.6.1.orig/Lib/distutils/sysconfig.py Python-3.6.1/Lib/distutils/sysconfig.py
---- Python-3.6.1.orig/Lib/distutils/sysconfig.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Lib/distutils/sysconfig.py 2017-03-22 21:42:23.915962369 +0200
-@@ -133,7 +133,7 @@
+diff -uar Python-3.6.2.orig/Lib/distutils/sysconfig.py Python-3.6.2/Lib/distutils/sysconfig.py
+--- Python-3.6.2.orig/Lib/distutils/sysconfig.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Lib/distutils/sysconfig.py 2017-08-20 15:10:41.654336706 +0300
+@@ -130,7 +130,7 @@
if os.name == "posix":
libpython = os.path.join(prefix,
@@ -33,9 +33,9 @@ diff -uar Python-3.6.1.orig/Lib/distutils/sysconfig.py Python-3.6.1/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.6.1.orig/Lib/site.py Python-3.6.1/Lib/site.py
---- Python-3.6.1.orig/Lib/site.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Lib/site.py 2017-03-22 21:42:23.915962369 +0200
+diff -uar Python-3.6.2.orig/Lib/site.py Python-3.6.2/Lib/site.py
+--- Python-3.6.2.orig/Lib/site.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Lib/site.py 2017-08-20 15:10:41.654336706 +0300
@@ -304,7 +304,7 @@
seen.add(prefix)
@@ -45,9 +45,9 @@ diff -uar Python-3.6.1.orig/Lib/site.py Python-3.6.1/Lib/site.py
"python%d.%d" % sys.version_info[:2],
"site-packages"))
else:
-diff -uar Python-3.6.1.orig/Lib/sysconfig.py Python-3.6.1/Lib/sysconfig.py
---- Python-3.6.1.orig/Lib/sysconfig.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Lib/sysconfig.py 2017-03-22 21:42:23.916962405 +0200
+diff -uar Python-3.6.2.orig/Lib/sysconfig.py Python-3.6.2/Lib/sysconfig.py
+--- Python-3.6.2.orig/Lib/sysconfig.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Lib/sysconfig.py 2017-08-20 15:10:41.654336706 +0300
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -93,10 +93,10 @@ diff -uar Python-3.6.1.orig/Lib/sysconfig.py Python-3.6.1/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.6.1.orig/Makefile.pre.in Python-3.6.1/Makefile.pre.in
---- Python-3.6.1.orig/Makefile.pre.in 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Makefile.pre.in 2017-03-22 21:42:23.916962405 +0200
-@@ -131,7 +131,7 @@
+diff -uar Python-3.6.2.orig/Makefile.pre.in Python-3.6.2/Makefile.pre.in
+--- Python-3.6.2.orig/Makefile.pre.in 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Makefile.pre.in 2017-08-20 15:10:41.655336736 +0300
+@@ -133,7 +133,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@@ -105,9 +105,9 @@ diff -uar Python-3.6.1.orig/Makefile.pre.in Python-3.6.1/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.6.1.orig/Modules/getpath.c Python-3.6.1/Modules/getpath.c
---- Python-3.6.1.orig/Modules/getpath.c 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/Modules/getpath.c 2017-03-22 21:42:23.917962441 +0200
+diff -uar Python-3.6.2.orig/Modules/getpath.c Python-3.6.2/Modules/getpath.c
+--- Python-3.6.2.orig/Modules/getpath.c 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/Modules/getpath.c 2017-08-20 15:10:41.655336736 +0300
@@ -494,7 +494,7 @@
_pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
_prefix = Py_DecodeLocale(PREFIX, NULL);
@@ -135,10 +135,10 @@ diff -uar Python-3.6.1.orig/Modules/getpath.c Python-3.6.1/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.6.1.orig/configure Python-3.6.1/configure
---- Python-3.6.1.orig/configure 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/configure 2017-03-22 21:42:23.920962550 +0200
-@@ -14963,9 +14963,9 @@
+diff -uar Python-3.6.2.orig/configure Python-3.6.2/configure
+--- Python-3.6.2.orig/configure 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/configure 2017-08-20 15:10:41.658336826 +0300
+@@ -15006,9 +15006,9 @@
if test x$PLATFORM_TRIPLET = x; then
@@ -150,9 +150,9 @@ diff -uar Python-3.6.1.orig/configure Python-3.6.1/configure
fi
-diff -uar Python-3.6.1.orig/setup.py Python-3.6.1/setup.py
---- Python-3.6.1.orig/setup.py 2017-03-21 08:32:38.000000000 +0200
-+++ Python-3.6.1/setup.py 2017-03-22 21:47:59.638077062 +0200
+diff -uar Python-3.6.2.orig/setup.py Python-3.6.2/setup.py
+--- Python-3.6.2.orig/setup.py 2017-07-08 06:33:27.000000000 +0300
++++ Python-3.6.2/setup.py 2017-08-20 15:10:41.659336856 +0300
@@ -491,7 +491,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index 4b1717187f..22b0ff40be 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=python3
SRCNAM=Python
-VERSION=${VERSION:-3.6.1}
+VERSION=${VERSION:-3.6.2}
BRANCH_VERSION=$(echo $VERSION | cut -f 1,2 -d . )
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
diff --git a/python/python3/python3.info b/python/python3/python3.info
index cf66871816..1e04dbbf3d 100644
--- a/python/python3/python3.info
+++ b/python/python3/python3.info
@@ -1,8 +1,8 @@
PRGNAM="python3"
-VERSION="3.6.1"
+VERSION="3.6.2"
HOMEPAGE="https://www.python.org/"
-DOWNLOAD="https://www.python.org/ftp/python/3.6.1/Python-3.6.1.tar.xz"
-MD5SUM="692b4fc3a2ba0d54d1495d4ead5b0b5c"
+DOWNLOAD="https://www.python.org/ftp/python/3.6.2/Python-3.6.2.tar.xz"
+MD5SUM="2c68846471994897278364fc18730dd9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""