summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Fernando Lopez Jr2017-08-17 01:18:03 +0200
committer Willy Sudiarto Raharjo2017-08-19 02:10:46 +0200
commit26e121ecbee487ccab303e7649be0a7162d9c1ae (patch)
tree68e9f52e67a2745bfdbba02a3dff20231272c7af
parent9e92e2bd36f3ccc9835f2116bff09b0a5bcf5dd2 (diff)
downloadslackbuilds-26e121ecbee487ccab303e7649be0a7162d9c1ae.tar.gz
system/routersploit: Added (exploitation framework).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--system/routersploit/README10
-rw-r--r--system/routersploit/routersploit.SlackBuild91
-rw-r--r--system/routersploit/routersploit.info10
-rw-r--r--system/routersploit/setup.py12
-rw-r--r--system/routersploit/slack-desc19
5 files changed, 142 insertions, 0 deletions
diff --git a/system/routersploit/README b/system/routersploit/README
new file mode 100644
index 0000000000..427ac153ff
--- /dev/null
+++ b/system/routersploit/README
@@ -0,0 +1,10 @@
+The RouterSploit Framework is an open-source exploitation framework
+dedicated to embedded devices.
+
+It consists of various modules that aid penetration testing operations:
+
+exploits - modules that take advantage of identified vulnerabilities
+creds - modules designed to test credentials against network services
+scanners - modules that check if a target is vulnerable to any exploit
+
+Optional dependency: python3
diff --git a/system/routersploit/routersploit.SlackBuild b/system/routersploit/routersploit.SlackBuild
new file mode 100644
index 0000000000..61938785da
--- /dev/null
+++ b/system/routersploit/routersploit.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for routersploit
+
+# Copyright 2017 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=routersploit
+VERSION=${VERSION:-2.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+rm requirements.txt
+cp $CWD/setup.py .
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md LICENSE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/routersploit/routersploit.info b/system/routersploit/routersploit.info
new file mode 100644
index 0000000000..f06bc5ff16
--- /dev/null
+++ b/system/routersploit/routersploit.info
@@ -0,0 +1,10 @@
+PRGNAM="routersploit"
+VERSION="2.2.1"
+HOMEPAGE="https://github.com/reverse-shell/routersploit"
+DOWNLOAD="https://github.com/reverse-shell/routersploit/archive/v2.2.1/routersploit-2.2.1.tar.gz"
+MD5SUM="62143935b564edbdd1703f6caa531296"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-requests paramiko BeautifulSoup4 pysnmp"
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/system/routersploit/setup.py b/system/routersploit/setup.py
new file mode 100644
index 0000000000..e039fa0758
--- /dev/null
+++ b/system/routersploit/setup.py
@@ -0,0 +1,12 @@
+from setuptools import setup
+
+setup(
+ name='routersploit',
+ version='2.2.1',
+ author='Reverse Shell Security',
+ packages=['routersploit','routersploit.modules','routersploit.templates','routersploit.test','routersploit.wordlists',],
+ scripts=['rsf.py',],
+ license='BSD-3-clause',
+ long_description=open('README.md').read(),
+ install_requires=['requests','paramiko','beautifulsoup4','pysnmp'],
+)
diff --git a/system/routersploit/slack-desc b/system/routersploit/slack-desc
new file mode 100644
index 0000000000..1ed0983c0d
--- /dev/null
+++ b/system/routersploit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+routersploit: routersploit (exploitation framework)
+routersploit:
+routersploit: The RouterSploit Framework is an open-source exploitation framework
+routersploit: dedicated to embedded devices.
+routersploit:
+routersploit: It consists of three modules that aid penetration testing operations:
+routersploit:
+routersploit: exploits - modules that take advantage of identified vulnerabilities
+routersploit: creds - modules designed to test credentials against network services
+routersploit: scanners - modules that check if a target is vulnerable to any exploit
+routersploit: