summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author M.Dinslage2017-06-06 23:36:55 +0200
committer Willy Sudiarto Raharjo2017-06-10 05:47:37 +0200
commitb24c8432844dfc41c1236dab10194c642b788c8c (patch)
treeabf0ef8a5711801383cfde4ccf01f42bfabd02d1
parent3653916b7edb433883e8ad8c941e33cf6a3c9aef (diff)
downloadslackbuilds-b24c8432844dfc41c1236dab10194c642b788c8c.tar.gz
system/conky: Fixed building with gcc-7.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--system/conky/conky.SlackBuild5
-rw-r--r--system/conky/conky.info2
2 files changed, 5 insertions, 2 deletions
diff --git a/system/conky/conky.SlackBuild b/system/conky/conky.SlackBuild
index 94b23e0261..f0ecaf36c5 100644
--- a/system/conky/conky.SlackBuild
+++ b/system/conky/conky.SlackBuild
@@ -78,7 +78,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -90,6 +90,9 @@ find -L . \
# fix MANDIR
sed -i 's,share/man/man1,man/man1,g' CMakeLists.txt
+# fix compile error with gcc-7.*
+sed -i "31i #include <functional>" src/luamm.hh
+
mkdir -p build
cd build
cmake \
diff --git a/system/conky/conky.info b/system/conky/conky.info
index f4929f80a9..86734c6b31 100644
--- a/system/conky/conky.info
+++ b/system/conky/conky.info
@@ -1,7 +1,7 @@
PRGNAM="conky"
VERSION="1.10.6"
HOMEPAGE="http://conky.sourceforge.net"
-DOWNLOAD="https://github.com/brndnmtthws/conky/archive/v1.10.6.tar.gz"
+DOWNLOAD="https://github.com/brndnmtthws/conky/archive/v1.10.6/conky-1.10.6.tar.gz"
MD5SUM="bcd9e0ff7304e14f07aea53efa73998f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""