summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andreas Guldstrand2017-06-08 14:33:47 +0200
committer Willy Sudiarto Raharjo2017-06-10 05:47:33 +0200
commit645645ca7171aec08ed5be3d1d3737aa567da5c3 (patch)
treeaaad8115d830dd4614db30d7409dfcbfb979ad24
parent513b39a920c428481f08a54e888be46bb28fc734 (diff)
downloadslackbuilds-645645ca7171aec08ed5be3d1d3737aa567da5c3.tar.gz
system/acd_cli: Removed (discontinued upstream).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--system/acd_cli/README5
-rw-r--r--system/acd_cli/acd_cli.SlackBuild88
-rw-r--r--system/acd_cli/acd_cli.info10
-rw-r--r--system/acd_cli/slack-desc19
4 files changed, 0 insertions, 122 deletions
diff --git a/system/acd_cli/README b/system/acd_cli/README
deleted file mode 100644
index c541398dac..0000000000
--- a/system/acd_cli/README
+++ /dev/null
@@ -1,5 +0,0 @@
-acd_cli provides a command line interface to Amazon Drive and allows
-Unix users to mount their drive using FUSE for read and (sequential)
-write access. It is currently in beta stage.
-
-All dependencies for this need to be built with python3 support.
diff --git a/system/acd_cli/acd_cli.SlackBuild b/system/acd_cli/acd_cli.SlackBuild
deleted file mode 100644
index ab684641f3..0000000000
--- a/system/acd_cli/acd_cli.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for acd_cli
-
-# Copyright 2017 Andreas Guldstrand
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=acd_cli
-VERSION=${VERSION:-0.3.2+3170d55}
-COMMIT="3170d55f82612558ef3a46df30ac43816482a7d2"
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$COMMIT
-tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
-cd $PRGNAM-$COMMIT
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CONTRIBUTING.rst LICENSE README.rst docs \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/acd_cli/acd_cli.info b/system/acd_cli/acd_cli.info
deleted file mode 100644
index 35654afd6c..0000000000
--- a/system/acd_cli/acd_cli.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="acd_cli"
-VERSION="0.3.2+3170d55"
-HOMEPAGE="https://github.com/yadayada/acd_cli"
-DOWNLOAD="https://github.com/yadayada/acd_cli/archive/3170d55f82612558ef3a46df30ac43816482a7d2/acd_cli-3170d55f82612558ef3a46df30ac43816482a7d2.tar.gz"
-MD5SUM="b28c6e43ed89396d8e692166a49cb2b5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3 python3-appdirs colorama python-dateutil python-requests requests-toolbelt SQLAlchemy python-fusepy"
-MAINTAINER="Andreas Guldstrand"
-EMAIL="andreas.guldstrand@gmail.com"
diff --git a/system/acd_cli/slack-desc b/system/acd_cli/slack-desc
deleted file mode 100644
index 6d34dabe46..0000000000
--- a/system/acd_cli/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-acd_cli: acd_cli (A command line interface and FUSE fs for Amazon Cloud Drive)
-acd_cli:
-acd_cli: acd_cli provides a command line interface to Amazon Drive and allows
-acd_cli: Unix users to mount their drive using FUSE for read and (sequential)
-acd_cli: write access. It is currently in beta stage.
-acd_cli:
-acd_cli: Website: https://github.com/yadayada/acd_cli
-acd_cli:
-acd_cli:
-acd_cli:
-acd_cli: