summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Mario Preksavec2017-06-06 12:59:04 +0200
committer Willy Sudiarto Raharjo2017-06-10 05:47:37 +0200
commit3d876becd37e669499d642317044bb48a6501f1b (patch)
tree61c6099820db93ab1ef7e0e85b0722390f2b5fb3
parent7140960adb05bdaecf1808a69c3bae56c64f528a (diff)
downloadslackbuilds-3d876becd37e669499d642317044bb48a6501f1b.tar.gz
libraries/libjson-rpc-cpp: Added (C++ framework for json-rpc).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--libraries/libjson-rpc-cpp/README2
-rw-r--r--libraries/libjson-rpc-cpp/libjson-rpc-cpp.SlackBuild109
-rw-r--r--libraries/libjson-rpc-cpp/libjson-rpc-cpp.info10
-rw-r--r--libraries/libjson-rpc-cpp/slack-desc19
4 files changed, 140 insertions, 0 deletions
diff --git a/libraries/libjson-rpc-cpp/README b/libraries/libjson-rpc-cpp/README
new file mode 100644
index 0000000000..4afac238d2
--- /dev/null
+++ b/libraries/libjson-rpc-cpp/README
@@ -0,0 +1,2 @@
+This framework provides cross platform JSON-RPC (remote procedure call)
+support for C++. It is fully JSON-RPC 2.0 & 1.0 compatible.
diff --git a/libraries/libjson-rpc-cpp/libjson-rpc-cpp.SlackBuild b/libraries/libjson-rpc-cpp/libjson-rpc-cpp.SlackBuild
new file mode 100644
index 0000000000..a4db63fc3a
--- /dev/null
+++ b/libraries/libjson-rpc-cpp/libjson-rpc-cpp.SlackBuild
@@ -0,0 +1,109 @@
+#!/bin/sh
+
+# Slackware build script for libjson-rpc-cpp
+
+# Copyright 2017 Mario Preksavec, Zagreb, Croatia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libjson-rpc-cpp
+VERSION=${VERSION:-0.7.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e 's#DESTINATION "lib/#DESTINATION "lib${LIB_SUFFIX}/#' src/stubgenerator/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCOMPILE_TESTS=NO \
+ -DCOMPILE_EXAMPLES=NO \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+# Manual labour :/
+mv $PKG/usr/share/man $PKG/usr
+rmdir $PKG/usr/share
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS.md CHANGELOG.md LICENSE.txt README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libjson-rpc-cpp/libjson-rpc-cpp.info b/libraries/libjson-rpc-cpp/libjson-rpc-cpp.info
new file mode 100644
index 0000000000..0a1c30c6d4
--- /dev/null
+++ b/libraries/libjson-rpc-cpp/libjson-rpc-cpp.info
@@ -0,0 +1,10 @@
+PRGNAM="libjson-rpc-cpp"
+VERSION="0.7.0"
+HOMEPAGE="https://github.com/cinemast/libjson-rpc-cpp"
+DOWNLOAD="https://github.com/cinemast/libjson-rpc-cpp/archive/v0.7.0/libjson-rpc-cpp-0.7.0.tar.gz"
+MD5SUM="6f17018d2f09227ad2855b48e4b7a844"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libmicrohttpd jsoncpp argtable"
+MAINTAINER="Mario Preksavec"
+EMAIL="mario at slackware dot hr"
diff --git a/libraries/libjson-rpc-cpp/slack-desc b/libraries/libjson-rpc-cpp/slack-desc
new file mode 100644
index 0000000000..5508656ba1
--- /dev/null
+++ b/libraries/libjson-rpc-cpp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libjson-rpc-cpp: libjson-rpc-cpp (C++ framework for json-rpc)
+libjson-rpc-cpp:
+libjson-rpc-cpp: This framework provides cross platform JSON-RPC support for C++.
+libjson-rpc-cpp: It is fully JSON-RPC 2.0 & 1.0 compatible.
+libjson-rpc-cpp:
+libjson-rpc-cpp: Homepage: https://github.com/cinemast/libjson-rpc-cpp
+libjson-rpc-cpp:
+libjson-rpc-cpp:
+libjson-rpc-cpp:
+libjson-rpc-cpp:
+libjson-rpc-cpp: