summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Edinaldo P. Silva2017-06-08 11:02:13 +0200
committer Willy Sudiarto Raharjo2017-06-10 05:47:40 +0200
commit3168a20f1f1607ef580f49e2060d6bbec07a176f (patch)
tree83db9bc1d2bef9c75b009be1cfaefa37234364db
parente43729282547f3b706650ba56c36c34f4378f216 (diff)
downloadslackbuilds-3168a20f1f1607ef580f49e2060d6bbec07a176f.tar.gz
python/python-faulthandler: Added (display Python traceback).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--python/python-faulthandler/README7
-rw-r--r--python/python-faulthandler/python-faulthandler.SlackBuild88
-rw-r--r--python/python-faulthandler/python-faulthandler.info10
-rw-r--r--python/python-faulthandler/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/python-faulthandler/README b/python/python-faulthandler/README
new file mode 100644
index 0000000000..39dbcfd553
--- /dev/null
+++ b/python/python-faulthandler/README
@@ -0,0 +1,7 @@
+python-faulthandler (Display the Python traceback on a crash)
+
+Fault handler for SIGSEGV, SIGFPE, SIGABRT, SIGBUS and SIGILL signals:
+display the Python traceback and restore the previous handler.
+
+Import the module and call faulthandler.enable() to enable the fault
+handler.
diff --git a/python/python-faulthandler/python-faulthandler.SlackBuild b/python/python-faulthandler/python-faulthandler.SlackBuild
new file mode 100644
index 0000000000..4eba95eae8
--- /dev/null
+++ b/python/python-faulthandler/python-faulthandler.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+#
+# Slackware build script for python-faulthandler.
+#
+# Copyright 2017 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-faulthandler
+VERSION=${VERSION:-2.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+SRCNAM="faulthandler"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root=$PKG --optimize=1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING README.rst TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-faulthandler/python-faulthandler.info b/python/python-faulthandler/python-faulthandler.info
new file mode 100644
index 0000000000..8625a82bb1
--- /dev/null
+++ b/python/python-faulthandler/python-faulthandler.info
@@ -0,0 +1,10 @@
+PRGNAM="python-faulthandler"
+VERSION="2.6"
+HOMEPAGE="https://pypi.python.org/pypi/faulthandler/"
+DOWNLOAD="https://pypi.python.org/packages/08/70/861aa647601cf1006f0d9b8ce1d17c37789d7637783eff8aacac4ed36ed6/faulthandler-2.6.tar.gz"
+MD5SUM="7ba7d707fe8f084e35f4f4b72b1f4b4d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/python/python-faulthandler/slack-desc b/python/python-faulthandler/slack-desc
new file mode 100644
index 0000000000..50f5bfa90f
--- /dev/null
+++ b/python/python-faulthandler/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-faulthandler: python-faulthandler (Display the Python traceback on a crash)
+python-faulthandler:
+python-faulthandler: Fault handler for SIGSEGV, SIGFPE, SIGABRT, SIGBUS and SIGILL signals:
+python-faulthandler: display the Python traceback and restore the previous handler.
+python-faulthandler:
+python-faulthandler: Import the module and call faulthandler.enable() to enable the fault
+python-faulthandler: handler.
+python-faulthandler:
+python-faulthandler: Homepage: https://pypi.python.org/pypi/faulthandler/
+python-faulthandler:
+python-faulthandler: