summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author melikamp2017-05-26 02:19:38 +0200
committer Willy Sudiarto Raharjo2017-05-27 02:31:05 +0200
commit682a1ce6663d7a30d56da9aa1d282a21deea693b (patch)
tree5c650b88bb9c33da50a311aef97c7ed1cb0ba387
parent4301848e7842b05a7493e3b9888831b76d712021 (diff)
downloadslackbuilds-682a1ce6663d7a30d56da9aa1d282a21deea693b.tar.gz
network/icecat: Updated for version 52.1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/icecat/README3
-rw-r--r--network/icecat/icecat.SlackBuild148
-rw-r--r--network/icecat/icecat.info10
3 files changed, 35 insertions, 126 deletions
diff --git a/network/icecat/README b/network/icecat/README
index cb978146f1..c5e388490a 100644
--- a/network/icecat/README
+++ b/network/icecat/README
@@ -25,3 +25,6 @@ want in the usual way:
information about the free software and privacy features in IceCat,
and checkboxes to enable and disable the ones more prone to break
websites. [COSMETIC]
+
+Disabled addons can be found in:
+/usr/lib${LIBDIRSUFFIX}/icecat-$VERSION/browser/disabled-extensions
diff --git a/network/icecat/icecat.SlackBuild b/network/icecat/icecat.SlackBuild
index 5a019d2a57..9ee893c603 100644
--- a/network/icecat/icecat.SlackBuild
+++ b/network/icecat/icecat.SlackBuild
@@ -25,7 +25,7 @@
# <http://www.gnu.org/licenses/>.
PRGNAM="icecat"
-VERSION=${VERSION:-45.7.0}
+VERSION=${VERSION:-52.1.0}
RELEASEVER="$VERSION"
RELEASEVERMAJ=$(echo $RELEASEVER | cut -f 1 -d .)
BUILD=${BUILD:-1}
@@ -33,7 +33,6 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -45,54 +44,27 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS=""
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
- OPTIMIZE=" --enable-optimize=-O2 "
- # On IA32, use gold since GNU ld runs out of memory linking libxul.so:
- PATH="$(pwd)/gold:$PATH"
- export CC="gcc -B$(pwd)/gold"
- export CXX="g++ -B$(pwd)/gold"
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
- OPTIMIZE=" --enable-optimize=-O2 "
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
- OPTIMIZE=" --enable-optimize=-O2 "
-elif [ "$ARCH" = "arm" ]; then
- SLKCFLAGS="-O2 -march=armv4 -mtune=xscale"
- LIBDIRSUFFIX=""
- OPTIMIZE=" --enable-optimize=-O2 "
-elif [ "$ARCH" = "armel" ]; then
- SLKCFLAGS="-O2 -march=armv4t"
- LIBDIRSUFFIX=""
- OPTIMIZE=" --enable-optimize=-O2 "
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
- OPTIMIZE=" --enable-optimize=-O2 "
fi
-# workaround to prevent unidentified crashes on some cpus
-OPTIMIZE="$(echo "$OPTIMIZE" | sed 's/O2/Os/g')"
-
-# When it works, it builds much faster.
-#NUMJOBS=${NUMJOBS:-" -j7 "}
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}-$VERSION-gnu1.tar.bz2
-cd ${PRGNAM}-$VERSION
-
-# https://bugzilla.mozilla.org/show_bug.cgi?id=1194520
-sed -e '/^ftglyph.h/i ftfntfmt.h' \
- -e '/^freetype\/ftcache.h/a freetype\/ftfntfmt.h' \
- -i config/system-headers
+mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
+cd $PKG/usr/lib${LIBDIRSUFFIX}
+tar xvf $CWD/${PRGNAM}-$VERSION.en-US.linux-$ARCH.tar.bz2
+mv ${PRGNAM} ${PRGNAM}-$VERSION
chown -R root:root .
find -L . \
@@ -101,101 +73,35 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Our building options, in a configure-like display ;)
-OPTIONS="\
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --with-system-zlib \
- --enable-application=browser \
- --enable-default-toolkit=cairo-gtk2 \
- --enable-startup-notification \
- --enable-crypto \
- --enable-svg \
- --enable-canvas \
- --enable-logging \
- --enable-xft \
- --enable-webm \
- --enable-xinerama \
- $OPTIMIZE \
- --enable-reorder \
- --enable-strip \
- --enable-cpp-rtti \
- --enable-single-profile \
- --enable-pulseaudio \
- --disable-gnomevfs \
- --disable-ldap \
- --disable-accessibility \
- --disable-crashreporter \
- --disable-debug \
- --disable-pedantic \
- --disable-installer \
- --disable-mailnews \
- --disable-composer \
- --enable-official-branding \
- --disable-elf-hack \
- --disable-profilesharing"
-# Complains about missing APNG support in Slackware's libpng:
-# --with-system-png \
-# This option breaks mozilla-12.0:
-# --enable-system-cairo \
-
-export CFLAGS="$SLKCFLAGS"
-export CXXFLAGS="$SLKCFLAGS"
-#export MOZ_MAKE_FLAGS="$NUMJOBS"
-
-# Clear some variables that could break the build
-unset DBUS_SESSION_BUS_ADDRESS ORBIT_SOCKETDIR SESSION_MANAGER \
- XDG_SESSION_COOKIE XAUTHORITY MAKEFLAGS
-
-# Assemble our .mozconfig, we use this method for building, seems
-# needed for PGO.
-echo ". \$topsrcdir/browser/config/mozconfig" > .mozconfig
-
-# Mozilla devs enforce using an objdir for building
-# https://developer.mozilla.org/en/Configuring_Build_Options#Building_with_an_objdir
-mkdir obj
-echo "mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj" >> .mozconfig
-
-# Write in it the options above
-for option in $OPTIONS; do echo "ac_add_options $option" >> .mozconfig; done
-
-echo "ac_add_options --disable-tests" >> .mozconfig
-make -f client.mk build
-make -f client.mk install DESTDIR=$PKG
-
-# We don't need these (just symlinks anyway):
-rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/icecat-devel-$RELEASEVER
-
-# Nor these:
-rm -rf $PKG/usr/include
-
-# OK, this is just awkward. Only OS-dependent addons should be in the
-# OS software channel, and the rest should be installed by the user,
-# or else the user gets stuck with unremovable addons. This especially
-# affects the adblockers, since some of them are incompatible.
-( cd $PKG/usr/lib${LIBDIRSUFFIX}/icecat-$RELEASEVER/browser/extensions \
- && rm -rf spyblock* jid1* https* html5* abouticecat* )
+mkdir $PKG/usr/bin
+cd $PKG/usr/bin
+ln -s /usr/lib${LIBDIRSUFFIX}/${PRGNAM}-$VERSION/icecat icecat
+
+# Only OS-dependent addons should be in the OS software channel, and
+# the rest should be installed by the user, or else the user gets
+# stuck with unremovable addons. This especially affects the
+# adblockers, since some of them are incompatible.
+
+cd $PKG/usr/lib${LIBDIRSUFFIX}/${PRGNAM}-$VERSION/browser
+mv extensions disabled-extensions
+mkdir -p extensions
+mv "disabled-extensions/abouticecat@gnu.org.xpi" \
+ "disabled-extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi" \
+ extensions/
# Desktop integration
mkdir -p $PKG/usr/share/applications
cat $CWD/icecat.desktop > $PKG/usr/share/applications/icecat.desktop
# Need some default icons in the right place:
-for i in 16 22 24 32 48 256; do
- install -m 0644 -D browser/branding/official/default${i}.png \
+cd $PKG/usr/lib${LIBDIRSUFFIX}/${PRGNAM}-$VERSION/browser/chrome/icons/default/
+for i in 16 32 48; do
+ install -m 0644 -D default${i}.png \
$PKG/usr/share/icons/hicolor/${i}x${i}/apps/icecat.png
done
-mkdir -p $PKG/usr/share/pixmaps
-( cd $PKG/usr/share/pixmaps ; ln -sf /usr/share/icons/hicolor/256x256/apps/icecat.png . )
-mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/icecat-$RELEASEVER/chrome/icons/default
-install -m 644 browser/branding/official/default16.png \
- $PKG/usr/lib$LIBDIRSUFFIX/icecat-$RELEASEVER/icons/
-install -m 644 browser/branding/official/default16.png \
- $PKG/usr/lib$LIBDIRSUFFIX/icecat-$RELEASEVER/chrome/icons/default/
# Stage documentation
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a Changelog.IceCat LEGAL LICENSE README.IceCat README.txt AUTHORS \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp $CWD/README* $CWD/Changelog.* $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/network/icecat/icecat.info b/network/icecat/icecat.info
index 9faec4cf56..f735dc12a7 100644
--- a/network/icecat/icecat.info
+++ b/network/icecat/icecat.info
@@ -1,10 +1,10 @@
PRGNAM="icecat"
-VERSION="45.7.0"
+VERSION="52.1.0"
HOMEPAGE="http://www.gnu.org/software/gnuzilla/"
-DOWNLOAD="https://ftp.gnu.org/gnu/gnuzilla/45.7.0/icecat-45.7.0-gnu1.tar.bz2"
-MD5SUM="d42424d2c7414ead53e776a2458697b6"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
+DOWNLOAD="https://ftp.gnu.org/gnu/gnuzilla/52.1.0/icecat-52.1.0.en-US.linux-i686.tar.bz2"
+MD5SUM="f2b8039ab5885c4ee27345cc5ff9c84d"
+DOWNLOAD_x86_64="https://ftp.gnu.org/gnu/gnuzilla/52.1.0/icecat-52.1.0.en-US.linux-x86_64.tar.bz2"
+MD5SUM_x86_64="fe2421a1133f242adea95f5e7e8d2a94"
REQUIRES=""
MAINTAINER="melikamp"
EMAIL="melikamp@melikamp.net"