summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2017-03-07 17:57:18 +0100
committer Willy Sudiarto Raharjo2017-03-11 01:03:49 +0100
commitbbb4977d1b04f8e97bbf5e3f8153a6b2f63b3e2e (patch)
treeba257f842e55877cbe410e5d916cd51506af08c4
parent6e451f93b06eba999770ec0e717930a975ff2d37 (diff)
downloadslackbuilds-bbb4977d1b04f8e97bbf5e3f8153a6b2f63b3e2e.tar.gz
python/pep8: Removed (per maintainer's request).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pep8/LICENSE.txt21
-rw-r--r--python/pep8/README2
-rw-r--r--python/pep8/pep8.SlackBuild69
-rw-r--r--python/pep8/pep8.info10
-rw-r--r--python/pep8/slack-desc19
5 files changed, 0 insertions, 121 deletions
diff --git a/python/pep8/LICENSE.txt b/python/pep8/LICENSE.txt
deleted file mode 100644
index c4610a9f6d..0000000000
--- a/python/pep8/LICENSE.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-Copyright (C) 2006 Johann C. Rocholl <johann@rocholl.net>
-
-Permission is hereby granted, free of charge, to any person
-obtaining a copy of this software and associated documentation files
-(the "Software"), to deal in the Software without restriction,
-including without limitation the rights to use, copy, modify, merge,
-publish, distribute, sublicense, and/or sell copies of the Software,
-and to permit persons to whom the Software is furnished to do so,
-subject to the following conditions:
-
-The above copyright notice and this permission notice shall be
-included in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
-BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
-ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
-CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/python/pep8/README b/python/pep8/README
deleted file mode 100644
index 295877cdef..0000000000
--- a/python/pep8/README
+++ /dev/null
@@ -1,2 +0,0 @@
-pep8 is a tool to check your Python code against some of the style
-conventions in PEP 8 <http://www.python.org/dev/peps/pep-0008/>.
diff --git a/python/pep8/pep8.SlackBuild b/python/pep8/pep8.SlackBuild
deleted file mode 100644
index 88356ae4c0..0000000000
--- a/python/pep8/pep8.SlackBuild
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pep8
-
-# Copyright 2012-2015 Audrius Kažukauskas <audrius@neutrino.lt>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pep8
-VERSION=${VERSION:-1.6.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/LICENSE.txt > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE.txt
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pep8/pep8.info b/python/pep8/pep8.info
deleted file mode 100644
index d803302f26..0000000000
--- a/python/pep8/pep8.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pep8"
-VERSION="1.6.2"
-HOMEPAGE="https://pep8.readthedocs.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pep8/pep8-1.6.2.tar.gz"
-MD5SUM="c7a3f57d832484a6295164661fbb1335"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
diff --git a/python/pep8/slack-desc b/python/pep8/slack-desc
deleted file mode 100644
index b9a776f282..0000000000
--- a/python/pep8/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pep8: pep8 (Check Python source code formatting)
-pep8:
-pep8: pep8 is a tool to check your Python code against some of the style
-pep8: conventions in PEP 8 <http://www.python.org/dev/peps/pep-0008/>.
-pep8:
-pep8: Homepage: https://pep8.readthedocs.org/
-pep8:
-pep8:
-pep8:
-pep8:
-pep8: