summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2017-01-24 14:22:23 +0100
committer Willy Sudiarto Raharjo2017-01-28 01:38:34 +0100
commite443415637eefd844fbcfd0433d55a78f44c33cf (patch)
tree7df74a3f4b441f526f01ccfd4e3bbfca0f230577
parentc974d2e630c7ac0825d8cdf8c2d486df7462bec4 (diff)
downloadslackbuilds-e443415637eefd844fbcfd0433d55a78f44c33cf.tar.gz
development/kelbt: Updated for version 0.16, cleanups.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--development/kelbt/kelbt.SlackBuild33
-rw-r--r--development/kelbt/kelbt.info6
2 files changed, 20 insertions, 19 deletions
diff --git a/development/kelbt/kelbt.SlackBuild b/development/kelbt/kelbt.SlackBuild
index 3fdb172cd7..73bf09973b 100644
--- a/development/kelbt/kelbt.SlackBuild
+++ b/development/kelbt/kelbt.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for kelbt
-# Copyright Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy, 2012
+# Copyright 2012-2017 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,13 +22,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=kelbt
-VERSION=${VERSION:-0.15}
+VERSION=${VERSION:-0.16}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -39,8 +39,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -64,30 +64,31 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i "s|\ compare| this->compare|" aapl/{avl,bst}common.h
-sed -i "s| compare| this->compare|" aapl/{avl,bst}common.h
+sed -i "s|\ compare| this->compare|" aapl/{avl,bst}common.h || exit 1
+sed -i "s| compare| this->compare|" aapl/{avl,bst}common.h || exit 1
+
+autoreconf -fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
-sed -i "s|-g|$SLKCFLAGS|" kelbt/Makefile
-
make
-install -D -m 0755 $PRGNAM/$PRGNAM $PKG/usr/bin/$PRGNAM
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+make install DESTDIR=$PKG
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING CREDITS ChangeLog TODO kelbt.vim $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING ChangeLog TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/kelbt/kelbt.info b/development/kelbt/kelbt.info
index 063cd56bd9..953f0bc782 100644
--- a/development/kelbt/kelbt.info
+++ b/development/kelbt/kelbt.info
@@ -1,8 +1,8 @@
PRGNAM="kelbt"
-VERSION="0.15"
+VERSION="0.16"
HOMEPAGE="http://freecode.com/projects/kelbt"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/kelbt-0.15.tar.gz"
-MD5SUM="c480692e26998edcc8735513c902cecc"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/kelbt-0.16.tar.gz"
+MD5SUM="4d85d72a6bf4a20ea2169e4a24bf16bc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""