summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Donald Cooley2017-01-25 12:05:17 +0100
committer Willy Sudiarto Raharjo2017-01-28 01:38:04 +0100
commit1da64aa476ecdf76ad156541924069a57c9430a3 (patch)
tree6b93d5f44525cdd59bd53f8ccd290406139f37ea
parent388723a7c0eb1e03b70bb7eec8e99496a1230522 (diff)
downloadslackbuilds-1da64aa476ecdf76ad156541924069a57c9430a3.tar.gz
system/trash-cli: Updated for version 0.17.1.14.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--system/trash-cli/README12
-rw-r--r--system/trash-cli/trash-cli.SlackBuild22
-rw-r--r--system/trash-cli/trash-cli.info8
3 files changed, 28 insertions, 14 deletions
diff --git a/system/trash-cli/README b/system/trash-cli/README
index 409df44aa9..3d1f4c8749 100644
--- a/system/trash-cli/README
+++ b/system/trash-cli/README
@@ -1 +1,11 @@
-trash-cli is a command line interface to the FreeDesktop.org trashcan.
+trash-cli trashes files recording the original path, deletion date, and
+permissions. It uses the same trashcan used by KDE, GNOME, and XFCE, but
+you can invoke it from the command line (and scripts).
+
+It provides these commands:
+
+trash-put : trashes files and directories.
+trash-empty : empty the trashcan(s).
+trash-list : list trashed files.
+trash-restore : restore a trashed file.
+trash-rm : remove individual files from trash can.
diff --git a/system/trash-cli/trash-cli.SlackBuild b/system/trash-cli/trash-cli.SlackBuild
index 8a3d03f900..a345343671 100644
--- a/system/trash-cli/trash-cli.SlackBuild
+++ b/system/trash-cli/trash-cli.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for the trash-cli utils.
#
# Copyright 2010 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
+# Copyright 2017 Donald Cooley South Haven, IN USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,16 +23,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Updated and reworked by Donald Cooley <dfc@warpmail.net>
PRGNAM=trash-cli
-VERSION=${VERSION:-0.12.9.14}
+VERSION=${VERSION:-0.17.1.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +42,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,8 +61,8 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -73,6 +73,9 @@ find -L . \
python setup.py install --root=$PKG
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir $PKG/usr/man
mv $PKG/usr/share/man/ $PKG/usr/
rmdir $PKG/usr/share
@@ -81,10 +84,11 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING CREDITS.txt DONE.txt HISTORY.txt MANIFEST.in README.rst TODO.txt bugs.txt requirements-dev.txt \
+cp -a \
+ COPYING CREDITS.txt DONE.txt HISTORY.txt README.rst TODO.txt \
+ bugs.txt requirements-dev.txt docs \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/system/trash-cli/trash-cli.info b/system/trash-cli/trash-cli.info
index 31e9dcc8b4..4e107d9bb4 100644
--- a/system/trash-cli/trash-cli.info
+++ b/system/trash-cli/trash-cli.info
@@ -1,10 +1,10 @@
PRGNAM="trash-cli"
-VERSION="0.12.9.14"
+VERSION="0.17.1.14"
HOMEPAGE="https://github.com/andreafrancia/trash-cli"
-DOWNLOAD="https://github.com/andreafrancia/trash-cli/archive/0.12.9.14.tar.gz"
-MD5SUM="53d6b696b7241b89216d520db7aa4c54"
+DOWNLOAD="https://github.com/andreafrancia/trash-cli/archive/0.17.1.14/trash-cli-0.17.1.14.tar.gz"
+MD5SUM="75ccadb291fdef88cd7175d609fc6409"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Donald Cooley"
-EMAIL="dfc@warpmail.net"
+EMAIL="chytraeu@sdf.org"