summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Barry J. Grundy2017-01-22 02:45:26 +0100
committer Willy Sudiarto Raharjo2017-01-24 01:22:55 +0100
commit71c04ee12226c6063d688ba6581a86b7d2b77f31 (patch)
tree1c073d27638e450d56c705dcc20b6ca92a8bd54a
parent0ae53b88497f400f648500c20bc5bf9c255167d1 (diff)
downloadslackbuilds-71c04ee12226c6063d688ba6581a86b7d2b77f31.tar.gz
python/yara-python: Added (Python for yara).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/yara-python/README8
-rw-r--r--python/yara-python/slack-desc19
-rw-r--r--python/yara-python/yara-python.SlackBuild89
-rw-r--r--python/yara-python/yara-python.info10
4 files changed, 126 insertions, 0 deletions
diff --git a/python/yara-python/README b/python/yara-python/README
new file mode 100644
index 0000000000..6bef9e57f0
--- /dev/null
+++ b/python/yara-python/README
@@ -0,0 +1,8 @@
+yara-python is a python library for YARA.
+
+YARA is a tool aimed at (but not limited to) helping malware researchers
+to identify and classify malware samples.
+
+With this library you can use YARA from your Python programs. It covers
+all YARA's features, from compiling, saving and loading rules to scanning
+files, strings and processes.
diff --git a/python/yara-python/slack-desc b/python/yara-python/slack-desc
new file mode 100644
index 0000000000..fdd18cb72c
--- /dev/null
+++ b/python/yara-python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+yara-python: yara-python (Python for yara)
+yara-python:
+yara-python: yara-python is a Python library to allow the use of YARA directly
+yara-python: in python programs. It covers all YARA's features, from compiling,
+yara-python: saving and loading rules to scanning files, strings and
+yara-python: processes.
+yara-python:
+yara-python: Homepage: https://github.com/VirusTotal/yara-python
+yara-python:
+yara-python:
+yara-python:
diff --git a/python/yara-python/yara-python.SlackBuild b/python/yara-python/yara-python.SlackBuild
new file mode 100644
index 0000000000..ddbe09f057
--- /dev/null
+++ b/python/yara-python/yara-python.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for yara-python
+# Copyright 2017 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# New build - v3.5.0, January 2017, Barry J. Grundy.
+
+PRGNAM=yara-python
+VERSION=${VERSION:-3.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf "$PRGNAM"-$VERSION
+tar xvf $CWD/"$PRGNAM"-$VERSION.tar.gz
+cd "$PRGNAM"-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+export CC="gcc $SLKCFLAGS $(pkg-config --cflags talloc)"
+
+python setup.py build --dynamic-linking
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/yara-python/yara-python.info b/python/yara-python/yara-python.info
new file mode 100644
index 0000000000..5ac8fd06f7
--- /dev/null
+++ b/python/yara-python/yara-python.info
@@ -0,0 +1,10 @@
+PRGNAM="yara-python"
+VERSION="3.5.0"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+DOWNLOAD="https://github.com/VirusTotal/yara-python/archive/v3.5.0/yara-python-3.5.0.tar.gz"
+MD5SUM="a6dc00c73deabf1dcf3581c5573280eb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="yara"
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"