summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2017-01-22 10:26:01 +0100
committer Willy Sudiarto Raharjo2017-01-24 01:22:58 +0100
commit1e1aa5d236b40bb5d443763e9cf762133bf438b0 (patch)
treed0d9e6f85d340dfb67df8739196609abc86376fa
parentbf24140aa622523ac3d979e3793f88e6d82d816f (diff)
downloadslackbuilds-1e1aa5d236b40bb5d443763e9cf762133bf438b0.tar.gz
python/python-axolotl-curve25519: Added (python wrapper).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-axolotl-curve25519/README4
-rw-r--r--python/python-axolotl-curve25519/python-axolotl-curve25519.SlackBuild91
-rw-r--r--python/python-axolotl-curve25519/python-axolotl-curve25519.info10
-rw-r--r--python/python-axolotl-curve25519/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/python-axolotl-curve25519/README b/python/python-axolotl-curve25519/README
new file mode 100644
index 0000000000..3ac53ad3fd
--- /dev/null
+++ b/python/python-axolotl-curve25519/README
@@ -0,0 +1,4 @@
+python-axolotl-curve25519
+
+Python wrapper for curve25519 library with ed25519 signatures
+This wrapper is meant for use by python-axolotl.
diff --git a/python/python-axolotl-curve25519/python-axolotl-curve25519.SlackBuild b/python/python-axolotl-curve25519/python-axolotl-curve25519.SlackBuild
new file mode 100644
index 0000000000..596e4895f3
--- /dev/null
+++ b/python/python-axolotl-curve25519/python-axolotl-curve25519.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for python-axolotl-curve25519
+
+# Copyright 2016-2017 Andrew Clemons, Wellington New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-axolotl-curve25519
+GITREV=${GITREV:-e4a9c4de0eae27223200579c58d1f8f6d20637e2}
+VERSION=${VERSION:-git$(echo "$GITREV" | sed 's/^\(.\{7\}\).*$/\1/')}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$GITREV
+tar xvf $CWD/$PRGNAM-$GITREV.tar.gz
+cd $PRGNAM-$GITREV
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ CFLAGS="$SLKCFLAGS" python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-axolotl-curve25519/python-axolotl-curve25519.info b/python/python-axolotl-curve25519/python-axolotl-curve25519.info
new file mode 100644
index 0000000000..bf671d870a
--- /dev/null
+++ b/python/python-axolotl-curve25519/python-axolotl-curve25519.info
@@ -0,0 +1,10 @@
+PRGNAM="python-axolotl-curve25519"
+VERSION="gite4a9c4d"
+HOMEPAGE="https://github.com/tgalal/python-axolotl-curve25519"
+DOWNLOAD="https://github.com/tgalal/python-axolotl-curve25519/archive/e4a9c4de0eae27223200579c58d1f8f6d20637e2/python-axolotl-curve25519-e4a9c4de0eae27223200579c58d1f8f6d20637e2.tar.gz"
+MD5SUM="44bc4d9bd172653781bf07ad4288cba2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/python/python-axolotl-curve25519/slack-desc b/python/python-axolotl-curve25519/slack-desc
new file mode 100644
index 0000000000..ebda50ab52
--- /dev/null
+++ b/python/python-axolotl-curve25519/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-axolotl-curve25519: python-axolotl-curve25519 (python wrapper for curve25519 library)
+python-axolotl-curve25519:
+python-axolotl-curve25519: This is python wrapper for curve25519 library with ed25519 signatures
+python-axolotl-curve25519: The C code was pulled from libaxolotl-android. At the moment this
+python-axolotl-curve25519: wrapper is meant for use by python-axolotl python-axolotl-curve25519.
+python-axolotl-curve25519:
+python-axolotl-curve25519:
+python-axolotl-curve25519:
+python-axolotl-curve25519: https://github.com/tgalal/python-axolotl-curve25519
+python-axolotl-curve25519:
+python-axolotl-curve25519: