summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andre Fernando2017-01-20 18:23:10 +0100
committer Willy Sudiarto Raharjo2017-01-21 00:24:16 +0100
commitc03d26ced347f7f69b50dd2365ff2cd626b252c7 (patch)
tree29a52255260c133692f52f72077a09cd9d15ffea
parent17e4c5263288b29c3f570b5ee588aa374385839d (diff)
downloadslackbuilds-c03d26ced347f7f69b50dd2365ff2cd626b252c7.tar.gz
system/hashcat: Added (advanced password recovery).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/hashcat/README5
-rw-r--r--system/hashcat/hashcat.SlackBuild92
-rw-r--r--system/hashcat/hashcat.info10
-rw-r--r--system/hashcat/patches/dir.patch11
-rw-r--r--system/hashcat/slack-desc19
5 files changed, 137 insertions, 0 deletions
diff --git a/system/hashcat/README b/system/hashcat/README
new file mode 100644
index 0000000000..030ea13c73
--- /dev/null
+++ b/system/hashcat/README
@@ -0,0 +1,5 @@
+hashcat is the world's fastest and most advanced password recovery
+utility, supporting five unique modes of attack for over 160
+highly-optimized hashing algorithms. hashcat currently supports CPU's,
+GPU's other hardware-accelerators on Linux, Windows and OSX, and has
+facilities to help enable distributed password cracking.
diff --git a/system/hashcat/hashcat.SlackBuild b/system/hashcat/hashcat.SlackBuild
new file mode 100644
index 0000000000..d251149e06
--- /dev/null
+++ b/system/hashcat/hashcat.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for hashcat
+
+# Copyright 2017 Andre Fernando, Indonesia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=hashcat
+VERSION=${VERSION:-3.30}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+for i in $(ls $CWD/patches); do
+ patch -p0 < $CWD/patches/$i
+done
+
+sed -i "s|/lib|/lib${LIBDIRSUFFIX}|" src/Makefile
+sed -i "s|share/doc/hashcat|doc/$PRGNAM-$VERSION|" src/Makefile
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/hashcat/hashcat.info b/system/hashcat/hashcat.info
new file mode 100644
index 0000000000..e69114ba93
--- /dev/null
+++ b/system/hashcat/hashcat.info
@@ -0,0 +1,10 @@
+PRGNAM="hashcat"
+VERSION="3.30"
+HOMEPAGE="https://hashcat.net/hashcat/"
+DOWNLOAD="https://hashcat.net/files/hashcat-3.30.tar.gz"
+MD5SUM="7f5682ddad66bd46972d07e1f2c00fa0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="opencl-headers"
+MAINTAINER="Andre Fernando"
+EMAIL="ando344@gmail.com"
diff --git a/system/hashcat/patches/dir.patch b/system/hashcat/patches/dir.patch
new file mode 100644
index 0000000000..7049312ac7
--- /dev/null
+++ b/system/hashcat/patches/dir.patch
@@ -0,0 +1,11 @@
+--- src/Makefile
++++ src/Makefile
+@@ -40,7 +40,7 @@
+ ##
+
+ DESTDIR ?=
+-PREFIX ?= /usr/local
++PREFIX ?= /usr
+
+ INSTALL_FOLDER ?= $(PREFIX)/bin
+ LIBRARY_FOLDER ?= $(PREFIX)/lib
diff --git a/system/hashcat/slack-desc b/system/hashcat/slack-desc
new file mode 100644
index 0000000000..d937799af9
--- /dev/null
+++ b/system/hashcat/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hashcat: hashcat (advanced password recovery)
+hashcat:
+hashcat: hashcat is the world's fastest and most advanced password recovery
+hashcat: utility, supporting five unique modes of attack for over 160
+hashcat: highly-optimized hashing algorithms. hashcat currently supports
+hashcat: CPU's, GPU's other hardware-accelerators on Linux, Windows and OSX,
+hashcat: and has facilities to help enable distributed password cracking.
+hashcat:
+hashcat: Homepage: https://hashcat.net/hashcat/
+hashcat:
+hashcat: