summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andre Fernando2017-01-20 18:12:23 +0100
committer Willy Sudiarto Raharjo2017-01-21 00:24:16 +0100
commit17e4c5263288b29c3f570b5ee588aa374385839d (patch)
tree809e7d336203296d4cd5cbc6f090f8285f3cdef6
parenta96abf1faf5c7f6fde80e1b1bcc12fe8aa84b610 (diff)
downloadslackbuilds-17e4c5263288b29c3f570b5ee588aa374385839d.tar.gz
system/hashID: Added (hash-identifier).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/hashID/README4
-rw-r--r--system/hashID/hashID.SlackBuild91
-rw-r--r--system/hashID/hashID.info10
-rw-r--r--system/hashID/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/system/hashID/README b/system/hashID/README
new file mode 100644
index 0000000000..90691ad2ae
--- /dev/null
+++ b/system/hashID/README
@@ -0,0 +1,4 @@
+hashID
+
+Identify the different types of hashes used to encrypt data
+and especially passwords.
diff --git a/system/hashID/hashID.SlackBuild b/system/hashID/hashID.SlackBuild
new file mode 100644
index 0000000000..68a60358b7
--- /dev/null
+++ b/system/hashID/hashID.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for hashID
+
+# Copyright 2017 Andre Fernando, Indonesia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=hashID
+VERSION=${VERSION:-3.1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/bin
+install -D -m 0775 hashid.py $PKG/usr/bin/hash-identifier
+
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -a setup.py setup.cfg $PKG/usr/share/$PRGNAM-$VERSION
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/hashID/hashID.info b/system/hashID/hashID.info
new file mode 100644
index 0000000000..b72f150432
--- /dev/null
+++ b/system/hashID/hashID.info
@@ -0,0 +1,10 @@
+PRGNAM="hashID"
+VERSION="3.1.4"
+HOMEPAGE="https://psypanda.github.io/hashID/"
+DOWNLOAD="https://github.com/psypanda/hashID/archive/v3.1.4/hashID-3.1.4.tar.gz"
+MD5SUM="afc2329679c9d3564b8f2663e7917637"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Andre Fernando"
+EMAIL="ando344@gmail.com"
diff --git a/system/hashID/slack-desc b/system/hashID/slack-desc
new file mode 100644
index 0000000000..5ad8b77427
--- /dev/null
+++ b/system/hashID/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hashID: hashID (hash-identifier)
+hashID:
+hashID: Software to identify the different types of hashes used to encrypt
+hashID: data and especially passwords.
+hashID:
+hashID: Homepage: https://github.com/psypanda/hashID
+hashID:
+hashID:
+hashID:
+hashID:
+hashID: