summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andre Barboza2017-01-09 18:27:59 +0100
committer David Spencer2017-01-09 21:18:25 +0100
commit4838403e832fc03cbc65d6a05f407bfe00735e71 (patch)
treeb8f4633dea016c4e5d13d79653fae8549ce95d21
parent97eb668bfd49d20e32fcc188400ff337982ff5c4 (diff)
downloadslackbuilds-4838403e832fc03cbc65d6a05f407bfe00735e71.tar.gz
development/mstch: Added (templates in C++11).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/mstch/README11
-rw-r--r--development/mstch/mstch.SlackBuild96
-rw-r--r--development/mstch/mstch.info10
-rw-r--r--development/mstch/mstch.patch27
-rw-r--r--development/mstch/slack-desc19
5 files changed, 163 insertions, 0 deletions
diff --git a/development/mstch/README b/development/mstch/README
new file mode 100644
index 0000000000..61f8710ab9
--- /dev/null
+++ b/development/mstch/README
@@ -0,0 +1,11 @@
+mstch is a complete implementation of {{mustache}} templates using
+modern C++. It's compliant with specifications v1.1.3, including the
+lambda module.
+
+Supported features:
+- JSON-like data structure using Boost.Variant
+- variables, sections, inverted sections
+- partials
+- changing the delimiter
+- C++11 lambdas
+- C++ objects as view models
diff --git a/development/mstch/mstch.SlackBuild b/development/mstch/mstch.SlackBuild
new file mode 100644
index 0000000000..c61a7b3437
--- /dev/null
+++ b/development/mstch/mstch.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/sh
+
+# Slackware build script for mstch
+
+# Copyright 2017 Andre Barboza, Belo Horizonte - Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=mstch
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/mstch.patch
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/mstch/mstch.info b/development/mstch/mstch.info
new file mode 100644
index 0000000000..34134735a2
--- /dev/null
+++ b/development/mstch/mstch.info
@@ -0,0 +1,10 @@
+PRGNAM="mstch"
+VERSION="1.0.2"
+HOMEPAGE="https://github.com/no1msd/mstch/"
+DOWNLOAD="https://github.com/no1msd/mstch/archive/1.0.2/mstch-1.0.2.tar.gz"
+MD5SUM="306e7fead7480884f698ab47a6082e18"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
diff --git a/development/mstch/mstch.patch b/development/mstch/mstch.patch
new file mode 100644
index 0000000000..242113b77d
--- /dev/null
+++ b/development/mstch/mstch.patch
@@ -0,0 +1,27 @@
+diff -ur mstch-1.0.2.old/src/CMakeLists.txt mstch-1.0.2/src/CMakeLists.txt
+--- mstch-1.0.2.old/src/CMakeLists.txt 2016-02-01 18:08:46.000000000 -0200
++++ mstch-1.0.2/src/CMakeLists.txt 2017-01-09 12:52:26.414929590 -0200
+@@ -28,8 +28,8 @@
+
+ install(
+ TARGETS mstch EXPORT mstchTargets
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+
+ install(
+ FILES "${PROJECT_SOURCE_DIR}/include/mstch/mstch.hpp"
+@@ -55,10 +55,10 @@
+ EXPORT mstchTargets
+ FILE mstch-targets.cmake
+ NAMESPACE mstch::
+- DESTINATION lib/cmake/mstch)
++ DESTINATION lib${LIB_SUFFIX}/cmake/mstch)
+
+ install(FILES
+ "${PROJECT_SOURCE_DIR}/cmake/mstch-config.cmake"
+ "${CMAKE_CURRENT_BINARY_DIR}/mstch/mstch-config-version.cmake"
+- DESTINATION lib/cmake/mstch
++ DESTINATION lib${LIB_SUFFIX}/cmake/mstch
+ COMPONENT Devel)
diff --git a/development/mstch/slack-desc b/development/mstch/slack-desc
new file mode 100644
index 0000000000..a47377bfdc
--- /dev/null
+++ b/development/mstch/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mstch: mstch (templates in C++11)
+mstch:
+mstch: mstch is a complete implementation of {{mustache}} templates
+mstch: using modern C++. It's compliant with specifications v1.1.3,
+mstch: including the lambda module.
+mstch:
+mstch:
+mstch:
+mstch:
+mstch: https://github.com/no1msd/mstch
+mstch: