summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2016-09-12 03:42:28 +0200
committer Willy Sudiarto Raharjo2016-09-12 03:42:28 +0200
commit56526f5ca07bb25db66fb7ede9e571b359c640da (patch)
tree4442b0fef324a2a0ddc3bce39c5c78dacd25cbfb
parent4e7c837f4d3b0f9aac147451613f438fb7ca2e88 (diff)
downloadslackbuilds-56526f5ca07bb25db66fb7ede9e571b359c640da.tar.gz
system/fzf: Added (A command-line fuzzy finder).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/fzf/README6
-rw-r--r--system/fzf/fzf.SlackBuild114
-rw-r--r--system/fzf/fzf.info14
-rw-r--r--system/fzf/slack-desc19
4 files changed, 153 insertions, 0 deletions
diff --git a/system/fzf/README b/system/fzf/README
new file mode 100644
index 0000000000..183344cb39
--- /dev/null
+++ b/system/fzf/README
@@ -0,0 +1,6 @@
+fzf - A command-line fuzzy finder written in Go
+
+Vim Users: A fzf.vim plugin is included in /usr/share/fzf/vim/.
+
+NOTE: google-go-lang is only needed at compile time - not at runtime.
+
diff --git a/system/fzf/fzf.SlackBuild b/system/fzf/fzf.SlackBuild
new file mode 100644
index 0000000000..c54f647b07
--- /dev/null
+++ b/system/fzf/fzf.SlackBuild
@@ -0,0 +1,114 @@
+#!/bin/sh
+
+# Slackware build script for fzf
+
+# Copyright 2016 Andrew Clemons, Wellington New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=fzf
+VERSION=${VERSION:-0.13.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+sed -i 's/cd \$(SRCDIR) && go get/cd \$(SRCDIR)/' src/Makefile
+
+mkdir -p gopath/src/github.com/junegunn/
+
+tar xf $CWD/63c378b8 2> /dev/null || tar xf $CWD/junegunn-go-runewidth-travisish-26-g63c378b.tar.gz
+mv junegunn-go-runewidth-63c378b gopath/src/github.com/junegunn/go-runewidth
+
+tar xf $CWD/35d512af 2> /dev/null || tar xf $CWD/junegunn-go-shellwords-35d512a.tar.gz
+mv junegunn-go-shellwords-35d512a gopath/src/github.com/junegunn/go-shellwords
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+(
+ cd src
+ make
+
+ mkdir -p $PKG/usr/bin
+ install -m 0755 fzf/fzf-linux_* $PKG/usr/bin/fzf
+)
+
+install -m 0755 bin/fzf-tmux $PKG/usr/bin/fzf-tmux
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/man/man1
+install -m 0644 man/man1/fzf.1 $PKG/usr/man/man1/fzf.1
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/share/bash-completion/completions/
+install -m 0644 shell/completion.bash $PKG/usr/share/bash-completion/completions/fzf
+
+mkdir -p $PKG/usr/share/zsh/site-functions/
+install -m 0644 shell/completion.zsh $PKG/usr/share/zsh/site-functions/_fzf
+
+mkdir -p $PKG/usr/share/fzf/vim/
+install -m 0644 plugin/fzf.vim $PKG/usr/share/fzf/vim/
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/go
+cp -a \
+ CHANGELOG.md LICENSE README.md shell/key-bindings.zsh shell/key-bindings.bash \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+
+chmod 0755 $PKG/usr/doc/$PRGNAM-$VERSION/key-bindings.*
+
+cp -a \
+ src/README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION/go
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/system/fzf/fzf.info b/system/fzf/fzf.info
new file mode 100644
index 0000000000..030d63e063
--- /dev/null
+++ b/system/fzf/fzf.info
@@ -0,0 +1,14 @@
+PRGNAM="fzf"
+VERSION="0.13.2"
+HOMEPAGE="https://github.com/junegunn/fzf"
+DOWNLOAD="https://github.com/junegunn/fzf/archive/0.13.5.tar.gz \
+ https://github.com/junegunn/go-shellwords/tarball/35d512af \
+ https://github.com/junegunn/go-runewidth/tarball/63c378b8"
+MD5SUM="9362b9ebebdb7bbf8de77dffe275a813 \
+ c5bbe751a0bb3a129c982af11fee54bb \
+ 77a5a798f5c3fe09f8cb7d12e218e560"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="google-go-lang"
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/system/fzf/slack-desc b/system/fzf/slack-desc
new file mode 100644
index 0000000000..d329c5baf6
--- /dev/null
+++ b/system/fzf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+fzf: fzf (A command-line fuzzy finder written in Go)
+fzf:
+fzf: fzf is a general-purpose command-line fuzzy finder.
+fzf:
+fzf: https://github.com/junegunn/fzf
+fzf:
+fzf:
+fzf:
+fzf:
+fzf:
+fzf: