summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Markus Reichelt2016-09-11 03:07:09 +0200
committer Willy Sudiarto Raharjo2016-09-11 03:07:09 +0200
commit79e7ad9b65f232c4dee4a3330ddb3394d07fa33c (patch)
tree3c3118d49c1965e98e1c4c0d0a6f59d67c50827d
parent72322f2030b623e61637739bcae58d3a6e67cad4 (diff)
downloadslackbuilds-79e7ad9b65f232c4dee4a3330ddb3394d07fa33c.tar.gz
python/attrs: Added (attributes without boilerplate).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/attrs/README3
-rw-r--r--python/attrs/attrs.SlackBuild85
-rw-r--r--python/attrs/attrs.info10
-rw-r--r--python/attrs/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/attrs/README b/python/attrs/README
new file mode 100644
index 0000000000..8f3e9d786e
--- /dev/null
+++ b/python/attrs/README
@@ -0,0 +1,3 @@
+attrs is an MIT-licensed Python package with class decorators that
+ease the chores of implementing the most common attribute-related
+object protocols.
diff --git a/python/attrs/attrs.SlackBuild b/python/attrs/attrs.SlackBuild
new file mode 100644
index 0000000000..e454fdd4d8
--- /dev/null
+++ b/python/attrs/attrs.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for attrs
+
+# Copyright 2016 Markus Reichelt, Aachen, DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=attrs
+VERSION=${VERSION:-16.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst docs/ LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/attrs/attrs.info b/python/attrs/attrs.info
new file mode 100644
index 0000000000..1448a80951
--- /dev/null
+++ b/python/attrs/attrs.info
@@ -0,0 +1,10 @@
+PRGNAM="attrs"
+VERSION="16.1.0"
+HOMEPAGE="https://pypi.python.org/pypi/attrs"
+DOWNLOAD="https://pypi.python.org/packages/b2/63/c969a9e1acca5922edf35f48552cdd40ec29f5bbb26fab6a3190b155a96e/attrs-16.1.0.tar.gz"
+MD5SUM="5bc532dde76f34ade746debabdfe1662"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Markus Reichelt"
+EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/attrs/slack-desc b/python/attrs/slack-desc
new file mode 100644
index 0000000000..c712e5ea33
--- /dev/null
+++ b/python/attrs/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+attrs: attrs (attributes without boilerplate)
+attrs:
+attrs: attrs is an MIT-licensed Python package with class decorators that
+attrs: ease the chores of implementing the most common attribute-related
+attrs: object protocols.
+attrs:
+attrs: Homepage: https://pypi.python.org/pypi/attrs
+attrs:
+attrs:
+attrs:
+attrs: