summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2016-09-11 03:49:52 +0200
committer Willy Sudiarto Raharjo2016-09-11 03:49:52 +0200
commit62a0fb786a427b6d832a3553ab05762a460045e4 (patch)
tree1b7be780662e724708d6e2287e91e4f4011cd489
parent27263a16a97dac510a92fca07304a37a1c1135b5 (diff)
downloadslackbuilds-62a0fb786a427b6d832a3553ab05762a460045e4.tar.gz
python/backports-abc: Added (backport of the collections.abc).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/backports-abc/README1
-rw-r--r--python/backports-abc/backports-abc.SlackBuild84
-rw-r--r--python/backports-abc/backports-abc.info10
-rw-r--r--python/backports-abc/slack-desc19
4 files changed, 114 insertions, 0 deletions
diff --git a/python/backports-abc/README b/python/backports-abc/README
new file mode 100644
index 0000000000..6dd7211229
--- /dev/null
+++ b/python/backports-abc/README
@@ -0,0 +1 @@
+Backport of the "collections.abc" stdlib module in Python 3.5.
diff --git a/python/backports-abc/backports-abc.SlackBuild b/python/backports-abc/backports-abc.SlackBuild
new file mode 100644
index 0000000000..47fef8f7bd
--- /dev/null
+++ b/python/backports-abc/backports-abc.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+#
+# SlackBuild for backports-abc
+#
+# Copyright 2016 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=backports-abc
+SRCNAM=backports_abc
+VERSION=${VERSION:-0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+JOBS=${JOBS:-1}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/backports-abc/backports-abc.info b/python/backports-abc/backports-abc.info
new file mode 100644
index 0000000000..efb9afc50a
--- /dev/null
+++ b/python/backports-abc/backports-abc.info
@@ -0,0 +1,10 @@
+PRGNAM="backports-abc"
+VERSION="0.4"
+HOMEPAGE="https://github.com/cython/backports_abc"
+DOWNLOAD="https://github.com/cython/backports_abc/archive/0.4/backports_abc-0.4.tar.gz"
+MD5SUM="96315e002208023b13ebca39d00a9ba2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/backports-abc/slack-desc b/python/backports-abc/slack-desc
new file mode 100644
index 0000000000..e613ab8506
--- /dev/null
+++ b/python/backports-abc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+backports-abc: backports-abc (backport of the collections.abc module)
+backports-abc:
+backports-abc: This provides a backport for the collections.abc module in Python 3.
+backports-abc:
+backports-abc:
+backports-abc:
+backports-abc:
+backports-abc:
+backports-abc:
+backports-abc:
+backports-abc: