summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Cristiano Urban2016-09-11 03:47:50 +0200
committer Willy Sudiarto Raharjo2016-09-11 03:47:50 +0200
commit27263a16a97dac510a92fca07304a37a1c1135b5 (patch)
treeae555d1aae5f2b6e96955c32dc80f0266cd41890
parent19e269e26e794044093cf88f85db8e920aa8761b (diff)
downloadslackbuilds-27263a16a97dac510a92fca07304a37a1c1135b5.tar.gz
misc/QCMA: Added (Cross-platform content manager assistant).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--misc/QCMA/QCMA.SlackBuild104
-rw-r--r--misc/QCMA/QCMA.info10
-rw-r--r--misc/QCMA/README12
-rw-r--r--misc/QCMA/doinst.sh9
-rw-r--r--misc/QCMA/slack-desc19
5 files changed, 154 insertions, 0 deletions
diff --git a/misc/QCMA/QCMA.SlackBuild b/misc/QCMA/QCMA.SlackBuild
new file mode 100644
index 0000000000..0a0a8a3cc1
--- /dev/null
+++ b/misc/QCMA/QCMA.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for QCMA
+
+# Copyright (c) 2016 Cristiano Urban, Gonars, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=QCMA
+VERSION=${VERSION:-0.3.13}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | tr '[:upper:]' '[:lower:]')"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+if [ "${QT5:-no}" == "yes" ]; then
+ lrelease-qt5 $SRCNAM.pro
+ qmake-qt5 LIBS+="-L/usr/lib${LIBDIRSUFFIX}" QMAKE_CFLAGS+="$SLKCFLAGS" \
+ QMAKE_CXXFLAGS+="$SLKCFLAGS" -o Makefile $SRCNAM.pro
+else
+ lrelease $SRCNAM.pro
+ qmake LIBS+="-L/usr/lib${LIBDIRSUFFIX}" QMAKE_CFLAGS+="$SLKCFLAGS" \
+ QMAKE_CXXFLAGS+="$SLKCFLAGS" -o Makefile $SRCNAM.pro
+fi
+
+make
+sed -i "s|usr/local|usr/|g" */Makefile
+make install INSTALL_ROOT=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/QCMA/QCMA.info b/misc/QCMA/QCMA.info
new file mode 100644
index 0000000000..d3f4a8a892
--- /dev/null
+++ b/misc/QCMA/QCMA.info
@@ -0,0 +1,10 @@
+PRGNAM="QCMA"
+VERSION="0.3.13"
+HOMEPAGE="https://codestation.github.io/qcma/"
+DOWNLOAD="https://github.com/codestation/qcma/archive/v0.3.13.tar.gz"
+MD5SUM="ee33b911def7e4772282c8db3d1b6658"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="ffmpeg VitaMTP"
+MAINTAINER="Cristiano Urban"
+EMAIL="cristiano.urban.slack@gmail.com"
diff --git a/misc/QCMA/README b/misc/QCMA/README
new file mode 100644
index 0000000000..f2620e8cb4
--- /dev/null
+++ b/misc/QCMA/README
@@ -0,0 +1,12 @@
+QCMA is a cross-platform application to provide a Open Source
+implementation of the original Content Manager Assistant that
+comes with the PS Vita. QCMA is meant to be compatible with
+Linux, Windows and MAC OS X.
+
+By default QCMA is built using the qt4 library. If you want to
+build QCMA using the qt5 library, you have to launch the script
+by passing the QT5 parameter:
+
+QT5=yes ./QCMA.SlackBuild
+
+qt5 is an optional dependency.
diff --git a/misc/QCMA/doinst.sh b/misc/QCMA/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/misc/QCMA/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/misc/QCMA/slack-desc b/misc/QCMA/slack-desc
new file mode 100644
index 0000000000..ce1c452e7e
--- /dev/null
+++ b/misc/QCMA/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+QCMA: QCMA (Cross-platform content manager assistant for the PS Vita)
+QCMA:
+QCMA: QCMA is a cross-platform application to provide a Open Source
+QCMA: implementation of the original Content Manager Assistant that
+QCMA: comes with the PS Vita. QCMA is meant to be compatible with
+QCMA: Linux, Windows and MAC OS X.
+QCMA:
+QCMA: Homepage: https://codestation.github.io/qcma/
+QCMA:
+QCMA:
+QCMA: