summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Markus Reichelt2016-09-11 03:09:01 +0200
committer Willy Sudiarto Raharjo2016-09-11 03:09:01 +0200
commit93ffbee6668adabee80a63d98c4a56edf2dfbc10 (patch)
tree158d09fa7e61541b153e2f422d359ff3066ff153
parent083a9e92319effd49b91eb52868da7cc240f6805 (diff)
downloadslackbuilds-93ffbee6668adabee80a63d98c4a56edf2dfbc10.tar.gz
python/python-twisted: Updated for version 16.4.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-twisted/python-twisted.SlackBuild16
-rw-r--r--python/python-twisted/python-twisted.info6
2 files changed, 11 insertions, 11 deletions
diff --git a/python/python-twisted/python-twisted.SlackBuild b/python/python-twisted/python-twisted.SlackBuild
index 594120d8bc..a2256e63b2 100644
--- a/python/python-twisted/python-twisted.SlackBuild
+++ b/python/python-twisted/python-twisted.SlackBuild
@@ -1,9 +1,9 @@
#!/bin/sh
-# Slackware build script for python-twisted.
+# Slackware build script for python-twisted
# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012-2015 Markus Reichelt, Stolberg (Rhld), DE
+# Copyright 2012-2016 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,13 +28,13 @@
PRGNAM=python-twisted
SRCNAM=Twisted
-VERSION=${VERSION:-15.2.1}
+VERSION=${VERSION:-16.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -45,8 +45,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -72,7 +72,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -81,7 +81,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- LICENSE NEWS README \
+ LICENSE* NEWS* README* \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/python-twisted/python-twisted.info b/python/python-twisted/python-twisted.info
index a6342b7588..1b7b7891c1 100644
--- a/python/python-twisted/python-twisted.info
+++ b/python/python-twisted/python-twisted.info
@@ -1,8 +1,8 @@
PRGNAM="python-twisted"
-VERSION="15.2.1"
+VERSION="16.4.0"
HOMEPAGE="http://twistedmatrix.com/"
-DOWNLOAD="https://pypi.python.org/packages/source/T/Twisted/Twisted-15.2.1.tar.bz2"
-MD5SUM="4be066a899c714e18af1ecfcb01cfef7"
+DOWNLOAD="https://twistedmatrix.com/Releases/Twisted/16.4/Twisted-16.4.0.tar.bz2"
+MD5SUM="688aa3dc9ef31aa012b76cca54129b38"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="zope.interface"