summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson2016-08-03 07:37:03 +0200
committer Willy Sudiarto Raharjo2016-08-13 02:22:55 +0200
commit88ce2ba0cbb387d7e91639a2ab5137287620b69d (patch)
tree4058e7c3d75f0e038de191d033a189898f6baa30
parent56ecb23094e52ff0e1cc4ae2208ea8315f29359a (diff)
downloadslackbuilds-88ce2ba0cbb387d7e91639a2ab5137287620b69d.tar.gz
system/isomd5sum: Updated for version 1.1.0, add Python 3 support.
-rw-r--r--system/isomd5sum/README5
-rw-r--r--system/isomd5sum/fix_makefile.diff19
-rw-r--r--system/isomd5sum/isomd5sum.SlackBuild26
-rw-r--r--system/isomd5sum/isomd5sum.info8
4 files changed, 27 insertions, 31 deletions
diff --git a/system/isomd5sum/README b/system/isomd5sum/README
index b37bc47360..1c20a61dae 100644
--- a/system/isomd5sum/README
+++ b/system/isomd5sum/README
@@ -4,5 +4,6 @@ iso given nothing more than the iso itself.
A checksum is implanted in an image using the implantisomd5 utility,
and the corresponding checkisomd5 utility can be used to verify burned
-CDs are error-free. Also included is a Python extension for performing
-these tasks.
+CDs are error-free. Also included is a Python 2 extension for performing
+these tasks. If Python 3 is installed, a Python 3 extension will also
+be included.
diff --git a/system/isomd5sum/fix_makefile.diff b/system/isomd5sum/fix_makefile.diff
deleted file mode 100644
index f048b33bb6..0000000000
--- a/system/isomd5sum/fix_makefile.diff
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naur isomd5sum-1.0.7/Makefile isomd5sum-1.0.7.patched//Makefile
---- isomd5sum-1.0.7/Makefile 2011-04-08 04:43:01.000000000 -0400
-+++ isomd5sum-1.0.7.patched//Makefile 2011-07-15 01:43:55.000000000 -0400
-@@ -29,9 +29,13 @@
- checkisomd5: checkisomd5.o libcheckisomd5.a
- $(CC) -lpopt $(CFLAGS) checkisomd5.o libcheckisomd5.a -o checkisomd5
-
--libimplantisomd5.a: libimplantisomd5.a(libimplantisomd5.o md5.o)
-+libimplantisomd5.a: libimplantisomd5.o md5.o
-+ ar rc libimplantisomd5.a libimplantisomd5.o md5.o
-+ ranlib libimplantisomd5.a
-
--libcheckisomd5.a: libcheckisomd5.a(libcheckisomd5.o md5.o)
-+libcheckisomd5.a: libcheckisomd5.o md5.o
-+ ar rc libcheckisomd5.a libcheckisomd5.o md5.o
-+ ranlib libcheckisomd5.a
-
- pyisomd5sum.so: $(PYOBJS)
- $(CC) -shared -g -o pyisomd5sum.so -fpic $(PYOBJS) $(LDFLAGS)
diff --git a/system/isomd5sum/isomd5sum.SlackBuild b/system/isomd5sum/isomd5sum.SlackBuild
index 8cfa66f69d..e40d5d12be 100644
--- a/system/isomd5sum/isomd5sum.SlackBuild
+++ b/system/isomd5sum/isomd5sum.SlackBuild
@@ -9,7 +9,7 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
PRGNAM=isomd5sum
-VERSION=${VERSION:-1.0.12}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -45,7 +45,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -54,13 +54,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/fix_makefile.diff
-
sed -i 's,/usr/share/man,/usr/man,' Makefile
sed -i -e 's/-Werror/ /' Makefile
-make RPM_OPT_FLAGS="$SLKCFLAGS"
-make install DESTDIR=$PKG
+# Build & install binaries, libs, and python2 support:
+make -j1 \
+ RPM_OPT_FLAGS="$SLKCFLAGS" \
+ PYTHON=python2 \
+ DESTDIR=$PKG \
+ all install
+
+# If python3 is installed, build support for it.
+# Slack's python 2.x package has a python2-config command, but SBo's
+# python 3.x doesn't have python3-config (only e.g. python3.3-config).
+# The readlink/which stuff avoids hard-coding 3.3 in this script:
+if python3 --version >/dev/null 2>&1; then
+ make -j1 \
+ RPM_OPT_FLAGS="$SLKCFLAGS" \
+ PYTHON=$( readlink $( which python3 ) ) \
+ DESTDIR=$PKG \
+ clean all install-python
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/system/isomd5sum/isomd5sum.info b/system/isomd5sum/isomd5sum.info
index 08baa55eca..8ff72b06ce 100644
--- a/system/isomd5sum/isomd5sum.info
+++ b/system/isomd5sum/isomd5sum.info
@@ -1,8 +1,8 @@
PRGNAM="isomd5sum"
-VERSION="1.0.12"
-HOMEPAGE="https://git.fedorahosted.org/git/isomd5sum.git"
-DOWNLOAD="https://git.fedorahosted.org/cgit/isomd5sum.git/snapshot/isomd5sum-1.0.12.tar.gz"
-MD5SUM="b96215095cb918e3900d0e586bd5f7ab"
+VERSION="1.1.0"
+HOMEPAGE="https://github.com/rhinstaller/isomd5sum/"
+DOWNLOAD="https://github.com/rhinstaller/isomd5sum/archive/1.1.0.tar.gz"
+MD5SUM="eac79ba8ecc16034339a8675a989833e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""