summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Heinz Wiesinger2015-05-23 18:44:38 +0200
committer Willy Sudiarto Raharjo2015-06-20 06:55:21 +0200
commit2f7f2cf4d8e815404c0814fe50a932d2bdf6744d (patch)
treec54c7f78d66c7cfffb41972ec50238a3e6c972e5
parentdbf4c04be62be254e5bd9ce8b1ddfe0b12d48f08 (diff)
downloadslackbuilds-2f7f2cf4d8e815404c0814fe50a932d2bdf6744d.tar.gz
desktop/ffmpegthumbnailer: Updated for version 2.0.10.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild40
-rw-r--r--desktop/ffmpegthumbnailer/ffmpegthumbnailer.info6
-rw-r--r--desktop/ffmpegthumbnailer/slack-desc2
3 files changed, 27 insertions, 21 deletions
diff --git a/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild b/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
index 5361c5a825..8c8b68db66 100644
--- a/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
+++ b/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for FFmpegthumbnailer
# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
-# Copyright 2012-2014 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2012-2015 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ffmpegthumbnailer
-VERSION=${VERSION:-2.0.9}
+VERSION=${VERSION:-2.0.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,21 +70,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-static=no \
- --enable-gio \
- --enable-thumbnailer \
- --build=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
+# Fix installing into correct libdir
+sed -i "s|\${CMAKE_INSTALL_PREFIX}/lib|\${CMAKE_INSTALL_PREFIX}/lib\${LIB_SUFFIX}|g" \
+ CMakeLists.txt
+
+mkdir build
+cd build
+ cmake \
+ -DCMAKE_CXX_FLAGS="${SLKCFLAGS}" \
+ -DCMAKE_C_FLAGS="${SLKCFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DENABLE_GIO="yes" \
+ -DENABLE_THUMBNAILER="yes" \
+ ..
+
+ make VERBOSE=1
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
diff --git a/desktop/ffmpegthumbnailer/ffmpegthumbnailer.info b/desktop/ffmpegthumbnailer/ffmpegthumbnailer.info
index fdc4610f71..28d41118d1 100644
--- a/desktop/ffmpegthumbnailer/ffmpegthumbnailer.info
+++ b/desktop/ffmpegthumbnailer/ffmpegthumbnailer.info
@@ -1,8 +1,8 @@
PRGNAM="ffmpegthumbnailer"
VERSION="2.0.9"
-HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer/"
-DOWNLOAD="http://www.liwjatan.at/files/src/ffmpegthumbnailer/ffmpegthumbnailer-2.0.9.tar.gz"
-MD5SUM="915450d09844d86e2d7fa50043d0924b"
+HOMEPAGE="https://github.com/dirkvdb/ffmpegthumbnailer"
+DOWNLOAD="https://github.com/dirkvdb/ffmpegthumbnailer/releases/download/2.0.10/ffmpegthumbnailer-2.0.10.tar.bz2"
+MD5SUM="3918d43b9d76c6e3eaf17e1c0c7dd5bc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="ffmpeg"
diff --git a/desktop/ffmpegthumbnailer/slack-desc b/desktop/ffmpegthumbnailer/slack-desc
index c29780d4e2..fb1a118607 100644
--- a/desktop/ffmpegthumbnailer/slack-desc
+++ b/desktop/ffmpegthumbnailer/slack-desc
@@ -14,6 +14,6 @@ ffmpegthumbnailer: The thumbnailer uses ffmpeg to decode frames from the video f
ffmpegthumbnailer: so supported videoformats depend on the configuration flags of
ffmpegthumbnailer: ffmpeg.
ffmpegthumbnailer:
-ffmpegthumbnailer: Homepage: http://code.google.com/p/ffmpegthumbnailer/
+ffmpegthumbnailer: Homepage: https://github.com/dirkvdb/ffmpegthumbnailer
ffmpegthumbnailer:
ffmpegthumbnailer: